Sleep Family / Thresholds ignored - Physics abruptly stop

I’m trying to give my sign some swinging physics, but it seems that the Sleep Family, Custom Sleep Threshold Multiplier and Stabilization Threshold Multiplier are ignored. The physics abruptly stop while the sign is still moving and the threshold numbers have no effect (tried 0 - 1000).
Settings in the video are the following:
Screenshot 2021-09-21 215209


I have the same problem in ue5 preview 1

1 Like

Same problem here…

ue5 preview 2 still has the same issue and no way to work around the issue.

UE5 5.0.0 and this is still occur and it’s very annoying… please fix this !!

1 Like

Having same issue on UE5 release, tried with custom sleep family and set both stabilization and sleep treshold to 10 milion but it’s completely ignored.

1 Like

Same problem here.
I have a pawn that is basically a physics object which the player controlls with thrusters.
Whenever there is no input, the physics object falls asleep. I tried to fake it by always adding a small amount of axis input with a constant float. But that also does not work.
So… yeah, please fix this.

1 Like

Yeah, for me I have a system where the player can grab object with the physics Handle but when I stop moving the object (so the camera) it falls asleep and freeze in the air, and I need to release it and grab it again :triumph:
And since it’s a main feature of my game, it’s very irritating …

Had the same problem. Ended up calling ->WakeInstance on part of the mesh in each Tick

1 Like

Same problem… i can’t disable auto sleep movement for my floating sci-fi drone T.T

Having the same problem in 5.0.2


Just discovered this today and yeah…

Its a real pain to deal with. Using Wake Rigid Body in blueprint was very helpful though.

1 Like

I fixed it by setting the thresholds to 0 in the physics material. I guess the other setting is simply ignored nowadays.


I’ve set all thresholds to zero in the physics material and have put WakeRigidBody nodes in my event tick - am still seeing the issue. Does anyone have any other suggestions?


This worked for me. Thanx for the tip. (UE 5.0.3)


you are a savior !

Actually puting a big number in sleep counter threshold do the trick, no need to put eveything else to 0 :slight_smile: