Download

SlateUI time in VR

Hello,

I am trying to do basic effects in a game. The Scene renders in around 6ms, SlateUI in around 4.6, and my WorldTick is 0.00. I can maintain 90fps no problem (So far I am using the editor).

why does SlateUI take 4.6ms? That is almost half the time!

However, sometimes, SlateUI jumps to 11 ms. Why is that? I am not showing any menus or type of UI.

Just trying to help so I’m really shooting in the wild here:

Could you try running the game from file explorer > right mouse click > “Launch game” , just to make sure you don’t have the editor ******** up your stats

edit: I’m seeing the same strange SlateUI behavior , even outside of the editor. (oculus rift cv1)
edit 2: (from Epic Staff) “Slate presents the whole backbuffer not just Slate so even without widgets you are still going to get that call.”
edit 3: I’m seeing dramatic improvements (from 4ms to .23ms) in the SlateUI time when I do “hmd mirror off” and then run “profilegpu” again

Thank you. I will try to see about that option.

I also noticed that GPUTime + WorldTick + SlateUI is always fixed to give 90 fps or 45fps…

So it seems that SlateUI also acts like compensator.

@omakke: I got the same problem with high ms for the slate ui, also with a cv1 and 4.14.1. Have you come to a solution? I just wondered if this 90fps or 45fps behaviour has something to do with this asynchronous-timewarp thing, oculus has implemented. But man, this is way above my skill level, so I’m just guessing here. I just find it strange, that the framerate is cut in half and that the framerate never drops to numbers between 90 to 45 fps.

Edit: Found another post, but I think this is something different, because I don’t have this EVGA installed.
cheers!

@andtheand: What I ended up doing is removing all “cast shadow” from every mesh, and for the world environment remove cast shadows.

After tweaking with lighting and shadows the problem is removed. Try to set the objects to static whenever you can for your scene (instead of movable or stationary).

If problem still persist, modify your materials to “unlit” and move lines going into base color to go into Emission. This will give it “flat” look.

I noticed also that SlateUI time = 11ms - x, where x is the rendering time. If I do more complicated scene, SlateUI time decreases and more time goes into the rendering.

When Rendering time > 11ms, then SlateUI + rendering time = 45 ms.

I hope that helps.

Thanks for the advice, I’ll give it a shot!