Download

Skylight_Lower Hemisphere color issue?

Hi all,
Is there a way to get the Lower hemisphere color to look correct in Lit mode. Color of the lower hemisphere was changed but still appears black in Lit mode but shows up correctly in the pathtracing mode. Is this a bug?
Thanks

Post the settings for skylight and atmosphere, please?

Posted the settings.
I didn’t change the settings that much. Also noticed that sunsky doesn’t work with pathtracing. Exponential height fog gets rid of the black part in lit mode but doesn’t work with pathtracing. So in the scene there is only a directional light, sky atmosphere and skylight. No exponential height fog.

It could be ray tracing for the static skylight. There’s a cvar called r.raytracing.globalillumination.evalskylight, set it to 1 to enable it. If RTGI is not enabled, or if global illumination is disabled too, then try turning off ray tracing in the skylight to see if, and which one(s), get the lower part of the sky to render the correct color.

If it’s not that, try changing the SkyAtmosphere Transform Mode to “Planet Top at Component Transform”.

If not that, try going through some of the Show Flags under Show dropdown in viewport (the first 4 categories in ‘All…’) to isolate the issue to its specific source. It’s a weird issue that I’m not sure the exact cause of in a static lighting scene.

Thanks for the help but none of it seems to work. Seems some other people have this issue:
https://answers.unrealengine.com/que…7230/view.html
https://answers.unrealengine.com/que…tmosphere.html
I updated to ue 4.26 preview 7 to see if maybe it has been fixed and the scene keeps crashing now.
For you, does this show correctly in Lit mode. I am wondering if this might be a graphics card issue.

Found this thread:
https://forums.unrealengine.com/unre…-model-in-4-24

Very informative read. So seems there is no way to eliminate the black horizon. @SebHillaire You have to create a sphere to cover the horizon?

In my version of 4.25.4, it doesn’t show a black area underneath the horizon line. I had the issue before in a different version and was able to fix it somehow, but I don’t remember how. I remember it had something to do with changing the atmospheric fog or Sky Atmosphere, and possibly a setting or two in the skylight. I’m going to start a new project with ray tracing and the SunSky to see if I get the black horizon issue. Then I’ll try to correct it.

Ok. Really appreciate the help. Thanks a lot Presto423.

Hello,
Yes you can create a skydome and control the bottom color yourself as it is show in the Time-Of-Day level template availabe when creating a new level.

Otherwise, as mention above by @presto423, you can set the planet planet transform mode to “Planet Top at Component Transform” and lower the component position to get some light scattering under your feet (then your level is higher up in the atmosphere so less *realistic-earth-like *atmosphere but fine if you expect to tweak it up yourself anyway).

Not sure how you got the second atmosphere screenshot on that page: height fog maybe? (because that is an actual third solution if I am not forgetting anything)

@SebHillaire The second atmosphere screenshot is when I switch to pathtracing mode just tweaking the lower hemisphere color and it shows correctly in the viewport. But Lit mode does not show this. Thanks for the explanation. Tried the suggestions. didn’t know you are supposed to lower the position. This is the best so far. I understand this is supposed to work with worlds to outer space. Most say the new sky atmosphere looks very photorealistic to set up accurate sky moods.
So I will try the planet route so it matches with both pathtracing and Lit mode.