Download

Skylight skyshadowing

Skylight with Lumen is blocked by roofs. Is there any way to adjust this effect to make interiors brighter? Is it still possible to create an ambient light that is not affected by anything?

Right now just do whatever. Play around. Don’t consider what you find out as the answer. That is all artistic and not really technical. That isn’t what the skylight is for. You could just make the ceiling non shadow casting when the player goes indoors with a world blueprint or something. You’d have to spawn the static mesh in the blueprint at load so you can modify it… At least last time I did that in UE4 you did, haven’t tried that in UE5 yet, sorry.

Edit: although… if you use the correct Lumen settings and hardware Lumen with the right lighting mode console command the propagated light from any windows or openings should be enough. You really only need skylight if you care about reflecting the volumetric clouds and sky atmosphere. Again, it’s artistic. Sometimes you get more lighting if you also have ray-trace shadows enabled in your project settings and in the Skylight settings.

Edit: this video might not help you in an obvious way because it’s completely unrelated but maybe just the visual content of this video that I did recently might spark some ideas even though I’m bug testing and trying to troubleshoot something but you could just kind of see what I’m doing right now… I dunno… It’s not with the Early Access version of the engine it’s with a now out of date ue5 main that I’ve compiled… But still

https://youtu.be/z4OtMmZtayQ

But making the ceiling non-shadow casting would allow every light including the directional light to pass through. Probably the Skylight wasn’t intended to be a global ambient light but it really did serve that purpose without Lumen. I know I can switch to other lighting methods but then again I really like Lumen for how dynamic it is.

I know I can light up an interior with more openings in the area but it isn’t quite the same. But well, I just want to know if such an option exists. Thanks for the answer :slight_smile:

simply turn off ‘Cast Shadows’ in your skylight



As you can see, turning off “Cast Shadows” in the Skylight makes no difference in Lumen.

Your interior looks black because you’re not setting your exposure. If you had properly set the exposure, you will see the interior is full of bounce light.

Honestly, if you aren’t going to bother setting your exposure your best option is to just turn Lumen off. You’re paying a steep performance cost for very little benefit. Just my opinion.

If you insist on working this way, you can add ambient light by using the “Ambient Cubemap” feature in the post process.

3 Likes

Alright. Thanks.