Download

Skylight radiates light from ground

Hello, after i bake my test level where outside has day but underground second landscape radiates some sort of light through because of Skylight(static mode). I even added some sort of massive ghostbox to block light from below but without any use. It affects movable objects that receives weird radiating light, on last picture i raised test mannequin up from ground and no bleed anymore. Walls are same that moving close to walls then character will receive that glow. Third picture is my attempt to make huge ghostbox(statif of course) to block bake light without success. One solution that works is just removing skylight but then i loose mild light bakes where i would want.

EDIT: Found it, Lightmass Importance Volume ended too soon and i resized little bit of more on Z axis and it fixed this issue. Leaving post here if someone will get similar issue but leaves lightmass importance volume size unnoticed.

](filedata/fetch?id=1870321&d=1615468841)

Bumping this issue back as on under roofs that are thick and even uses separate mesh modules outside/inside still radiates sunlight. Importance volume solved leaks from underground, but direct sunlight still radiates no matter i do. It happens especially close to walls that faces sun or under roof on second floor(picture). Is there solution for this at all without cranking baking quality to extreme levels but it takes too long to bake? This issue affects movable objects and when player would move into corner on there then he would glow like have eaten radiation cake.

If it is bleeding through from another room, you need thicker walls/floors and/or a more dense volumetric lightmap.

However some situations you just can’t easily solve, like having moveable objects (like doors) occluding indirect lighting. In situations like that your moveable objects will still be list as if there is no door there.

Another room has no light currently and all walls have good thickness and are not joined but separate meshes to avoid classic lightmap leaks that works actually well and is fine. What option controls volumetric lightmap density? It is daylight that somehow radiates from outside, espessially on sides where sun shines against walls/roofs.

You can get bleed on some walls and not others just based on how the meshes are placed in relation to the volumetric lightmap samples. It’s common to have a room with the same thickness walls on all sides but end up with light bleeding through just one side.

“Volumetric Lightmap Detail Cell Size” under the world settings tab with the other lightmass settings. The value is in centimeters so for a denser grid you’ll want to DECREASE it. By default it is set to 200, try 100 and see if that improves the result. You’ll probably also want to increase the maximum brick memory setting below that one.

Thank you so so much, yes seems that cell size is reason of that, sad is that build times are slower. Thank a lot. I iterate my constructs a lot and i build light lot of times to see another fixes i made on meshes.

](filedata/fetch?id=1872845&d=1616193730)