Skylight pitch black

When I set shadow quality to low or medium, and open a new level with skylight, it all looks pitch black except the point lights. It looks as if the skylight intensity is set to zero. But when I change the shadow quality to high or epic, it only makes the volumetric fog visible and still no skylight. If I restart the level after setting the shadow quality to high or epic, the skylight works normal, even if I set the shadow quality back to low or medium while the level is open. So the level of setting affects the skylight’s function at the opening of the level, and does not change until the level is restarted.

Is it normal to have no skylight when the shadow quality is low or medium at the loading of the level?

try hitting the recapture button on the skylight, see if that does anything. seems like odd behaviour to me though.

Make sure the “affects world” option is checked on, if it’s not then your skylight is turned off.

When I hit Recapture button, it updates the skylight in the editor as if the game has started. If the shadow quality was left on medium, the button makes the level too dark again.

very odd. i remember reading a while ago someone had a bugged skylight, tried all sorts to fix it and nothing worked, it wasn’t until they deleted the skylight and placed a new one that fix itself. maybe try that?

The game has ten levels each with different skylight. This issue happens in indoor levels, where the directional light is blocked by meshes. As a workaround I prevented the player from going lower than high shadow quality setting, for now.

If your skylight remains black when using SLS Captured Scene, it could be that your Sky Distance Threshold is too high. What happens is it tries to capture the light outside of the skybox, making it black.
Either scale up your skybox or lower the Sky Distance Threshold in the skylight.

1 Like

This solved it!! I added a skybox that’s not very big, simply increased the size and it started working again! thank you

Just keep in mind, this Sky distance threshold acts as a MINIMUM radius, from which it starts to capture the surrounding area - not as a maximum radius. So if you have a threshold of f.e. 1000, then it will only capture objects, that are 1000 or more units away from the center of your skylight. Everything closer will be ignored - and thats why you either need to increse your skybox size, or lower your threshold :slight_smile:

This is good to exclude some objects, that should not be part of the overall light situation captured by the skylight, cuz as the name implies, it should mainly just capture the overall sky ^.^ Recently found this video. He couldn’t have explained skylights better