Download

Skylight not rendering with realtime capture enabled

I have a dynamic skylight which is sourcing an hdri texture (starter content map). I have turned on cast raytrace shadows and realtime capture on the skylight’s parameters

Everything looks fine in the editor’s viewport and I get what is expected (proper raytraced shadows/reflections) for the skylight.

When I capture a movie via the sequencer, the skylight has no illumination.

Here is what I see in the editor’s viewport.

Here is a frame from the rendered capture.

If I turn realtime capture off, it renders the light. I am using version 4.26.1

Has anyone seen this behaviour before?

That may have to do with auto exposure, if it’s lowering the exposure due to the outside being bright

I have no auto exposure present, I am using manual camera settings in the ppv

Not sure how you have lighting with real-time enabled on the skylight since it only captures the new Sky Atmosphere, fog, and volumetric clouds. But either way, it’s not needed if you’re capturing a HDRI in the skylight.

If I don’t have real time capture enabled (when sourcing an hdri cube map in the skylight) I don’t get correct raytraced shadows/reflections, reflection look ups don’t have any occluders. For example, if you have a floor in a room with some reflective material, I see highlights/reflections of the sky from the hdr map. This is incorrect as the walls should be occluding this.

Turning on realtime capture fixes this issue. This looks correct in the viewport, but goes black when I render for some reason.

Hello,
Just to say that we have also discovered this issue: **sky light real time capture + sky light ray traced shadows are not working together **as of today (evolving sky light color won’t be taken into account). We have a task to fix that in a future release. What you observe here may be related.

As noted by @rosegoldslugs , if you are using a HDRi/cubemap, you indeed should not need real time capture because it is static. We need to fix the UI and merge real-time capture mode in the drop down. SkyLight doc just in case you need more info.

Thanks for the info. Just to show you an example of what I was getting.

This image is with real time capture turned off

This image is with real time capture turned on

I found that if I set the sky light’s mobility to stationary (previously movable), turn the real time capture off, turn “affect raytraced reflections” off, I get the result of the second image. Which looks like the results I am trying to achieve and renders fine.

I haven’t test enough yet to see if there are any drawbacks with this approach

hello still no fix for this?? as I am facing the same issue