Download

SkyLight light Leaking Problem

I have created a room that is sealed with walls, floor and ceiling. All meshes have a thickness and they are static meshes. I have a directional light and a SkyLight in my level. When I build the lighting without the skyLight, the interior of the room is completely black. Once I add a skyLight with an HDR cubemap, and build the lighting, I notice that the light is leaking on the floor and ceiling. When I uncheck Show>Lighting Components> Specular, the leaking light dissapears. The leak does not appear to be from the GI at all, unless it gets pushed into specularity.

Lightmaps are properly laid out by hand to the grid for all meshes, especially since the Dir Light shadows do not leak. Also, AO is OFF.

As a test, I increased the lightmaps to 4K (yes overkill) and set the following world setting to no avail:

Static LT Lvl Scale: 0.4
Num Bncs: 3
Indirect Quality: 10.0
Indirect Lighting Smoothness: 0.75
Compress Lightmaps: OFF

I also tried to turn off texture streaming in the project settings in order to maximize the resolution being used but that did not help.

It does appear that the shadows from the skyLight are too blurry and might be allowing light to leak into the room. However, when I uncheck show>Lighting Components> Diffuse or GI, the leak does not dissapear. Only when specular is unchecked will the leak dissapear. This makes me think that it might be reflected light. I make the material 100% rough and set a value of zero to the spec, but the leak still exists.

I have enclosed a screengrab of the leaking light in a room with no light sources and completely sealed by intersecting floor and ceiling and also a shot of the exterior.

Any suggestions?

Have you placed a reflection capture inside the room? It sounds like you haven’t.

@Wilkes If I am trying to create a totally dark interior with no leaking light or GI, how does a reflection capture actor help me?

Well, based on the fact that the problem disappears when you disable specular, it sounds like the “light leak” is actually a reflection of a skylight or something like that. Did placing a reflection capture help? Make sure it encompasses the entire room.

Yes, thanks, that fixed the problem :slight_smile:
I am curious as to why the Reflection Capture Cube is fixing the issue? Can you explain or point me to a link?

The Skylight creates its own “Global” cubemap so reflections in the world can accurately reflect the environment, especially in dynamic environments. What you’re seeing is the reflection created by the skylight. By adding a reflection capture, you’re overriding the cubemap for the localized area with an individual reflection map. You don’t need to use a reflection cube. You can just use a Sphere Reflection Actor. Cubes are more EXPENSIVE to use than a normal Sphere Reflection.

@sbnewsom Now I understand. Thanks!