Skylight has stopped working in 4.20.2


i started a project yesterday in version 4.20. i set up a scene with lighting to render my character. before i closed the project for the day i had no issues.
Today however, when i opened the scene, everything was as i left it. Until I slightly increased the intensity of the skylight. Instead of getting brighter, it stopped emitting light to the scene altogether. Playing with the intensity had 0 effect.

I played with the settings for a bit to no success. I then tried to make a new scene to see if it would work there but nope still not working. I then created a new project, new empty scene, placed a box down, then the skylight. the skylight still emits 0 light regardless of its settings.

So I can no longer use the skylight in any project. this is baffling for me.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


I’ve been having the same problem for hours, the Skylight worked for a little while but then stopped working. Adjusting the intensity and angle suddenly no longer had any effect. Even after starting a new project Skylight still does nothing. At least now I can drop the issue since it’s not just me.