Download

Skylight color never goes away?

Hi and yet again another light question. This time the Skylight. How to remove that blue tint that comes with it.

I HAVE set the Light Color to Pure white or at least as white it let me.
I have also set the Environment Color to white under World Settings and Environment Intensity to 0.

What setting is telling the skylight to produce that blue tint? SkySphere? I also set all colors under Override Settings to white on the SkySphere just to see if it helped but nothing.

This is driving me mad. Why does it make that blue ting I just want a nice smooth fill light the SkyLight produces not the color.

Really need a good Architect light tutorial…

cheers

Have you tried using a custom cubemap?

no… heard about it but no idea how to do it :confused:

You can search for free hdr images on the net and find a lighting setting that suits you. Then import it into the editor and put it in Cubemap section of the skylight, and dont forget to set Source Type to Specified Cubemap.

ok I guess I will have to learn how to make a cubemap. Doesnt seem that easy. The part with aligning the 6 texture.

Thanks for the help

No, you dont need to turn anything into cubemap. Check out the images in these sites;

http://hdrmaps.com/freebies

http://www.hdrlabs.com/sibl/archive.html

You can get any of them and import it directly into the engine. You dont need to make any further modifications, just plug it into the Cubemap slot of the Skylight.

hmm yeah think that worked, need to tune the brightness amount or find a more suitable hdr. but it worked much better. Thank!
Was confused that I needed to cut it up and align into 6 parts and all that, its what it says on the web but perhaps thats for something else(reflection).

Anyway thanks again! You have kept me sane, for now :smiley:

Sorry to bump this old thread but I have the same problem (see screenshot)
Everything is way too blue because of the skylight and deep blue skysphere (and I don’t want to desaturate it)
I can’t use a cubemap because i’m using a realtime night and day cycle.
Is they’re a way to control how much of the skysphere color the skylight can use as light color? of course my skylight tint is set to full white too.

are you recapturing the skylight every hour or so in game? does your sky change colors based on the time? if no, then you could just use a white hdri and turn the intensity down as you approach night time. or you can have different hdri of different times of day and blend them together. or you can trick it if you don’t recapture at all by lowering the skys saturation, capture, then put it back to normal

Hi,

“are you recapturing the skylight every hour or so in game?”
More like every 5 min but yes, i’m recapturing the skylight.

“does your sky change colors based on the time?”
Yes

“if no, then you could just use a white hdri and turn the intensity down as you approach night time”
I tryied this but of course, it leads to white ambiant light. I’m not looking for a white ambiant light, I want the same tints but with less saturation.

The blue color can come from any of these:

Skylight direct lighting
Skylight indirect lighting
Environment color (Lightmass Indirect)
Reflection captures (Skylight or Reflection Environment)
Atmospheric Fog (simulates Reyleigh scattering, almost always casts a blue tint)

If your Skylight is not giving you the results you want you can set up your sky material to use a different color for Indirect GI, use a custom cubemap with the colors you want, adjust the skylight color to add more green and red to counteract the blue, or just replace the skylight entirely and use a basic environment color.

I tryied to set the skylight indirect lighting intensity to zero but it doesn’t change anything

I think it’s a precomputed lightmass settings, am I wrong? My lighting is full dynamic with “force no precomputed lighting” checked

I might give a look at this one. How can I control it?

I’m not using it, I tryed to disable my exponential height fog but doesn’t remove the saturated blue tint.

All I’m looking for is desaturate the skylight.
I don’t want to make it static, I want the skylight tint to match the skysphere color changes. (day, dawn, dusk, night, cloudy weather, etc).
I don’t want to make white or another color.
Using color curves, blending colors, etc. makes the lighting too much static.

It’s strange that we can add a tint to the skylight direct lighting but not having control on it’s saturation

Then that’s not causing the blue.

OK, then we’ll rule out any static baking.

If you have any reflection captures in your world, you need to alter the color and intensity of the capture.

OK, well, your skylight is causing this blue color, and something needs to be done to stop it.

In an all-dynamic or stationary pass I believe the skylight uses a reflection capture. It’s capturing your crazy blue sky and applying those colors everywhere. UE4 doesn’t provide any other controls for a skylight other than changing the tint color. The only alternative is to make your own cubemap. The best solution here is to change the color of the skylight! Try a light yellow, bit more on the orange side: that opposes the blue you’re having and will cause a desaturating effect on the final image.

I am having the same problem using a dynamic day night cycle. The sky light at sunset and noon is far too saturated (orange or blue). Is there anyway to lerp the scene capture with a neutral gray cubemap or something?

Add a Post Process to your level, make it infinite (if needed) and choose an LUT. If your LUT doesn’t match what you want, there are LUT editors online.

Posting here as I’m getting no help anywhere else and its hard to go fwd with level design with this issue and this thread comes as close to what I’m seeing as anything so it makes sense- so, this is a picture of 4.23 terrain I’m not seeing in 4.22 for ex.:
4.23_weirdLOOKING_nodes_TerrainMat_smaller.jpg
As you can see there is the blue on left I’m, as noted, not getting in4.23,and the blotchy textures, I’m also never seen before. Is it a corrupt texture possibly ? Is there away to force a texture engine default ?

…that lays out with pictures what is going on, clearly that when I zoom in to choose right click play from,and while in some small zones I do not have that issue as much or at all, when I do its glaring and area of terrain flooded to large degree with this dark blue color, that with same project slightly older ( sculpts to terrain are older so some terrain features missing compared to 4.24 and yes a few static stairs , with materials but not blue) in 4.22 there are none this weird dark blue blotches everywhere, and in some areas also as player walks, 3rd person , the shadow on ground overcomes shadow from other terrain tall area, and its just gone, though character inside said shadow , is shadowed…weird!!

Any idea why this is happening to just 4.23 and 4.24 with nearly identically sculpted terrain (world comp btw) ?

TY anyone, just want to get past this, and while I know how to use LUT, since issue isn’t affecting 4.22, seems silly to need to have to go down .