Download

Skylight causing weird lighting errors on moving ship

The skylight is causing a weird lighting issue with flickering, if I disable the shadows the issue persists.

Disabling the bloom and directional light the issue persists. The problem is entirely with the skylight.

I tried modifying rendering settings and they didn’t have effect.

Try the real time capture option.

Overall, can’t be sure. but remember that UE5 is :poop: anyway.
Until they actually release a final build there’s tons of things that can go wrong like this.

You can possibly also just delete the skylight and do without.

Instead of using the BS system they set up (in 4.24/25) which is “cool in theory” but “bad in practice”, go back to a sky-sphere system where you render the stars into a sphere.
If you are making a space game, it’s probably better.
There’s no Fog or Atmosphere in space. Even if localized PP fog makes space looks cooler than it is :stuck_out_tongue:

One suggestion I can make is disabling ambient occlusion for the project if it’s on. If it’s not, or even if it is, disable mesh distance fields. It appeared that the flickering was showing mesh distance field shadows on the ship’s mesh, which often produce cruddy looking shadowing and shadows where they shouldn’t be. If not disabling MDFs and/or AO, then open the ship mesh in the mesh editor of UE and go to Build > LOD0 settings. Increase distance field resolution to 2 or 3, or higher possibly, and/or enable ‘two-sided distance fields’. This produces distance fields that are more accurate for some meshes, and especially in lower light conditions.

The flickering is a different issue, I think. What is the directional light mobility, and are Cascaded Shadow Maps in use (if so, the distance setting for CSMs will be greater than 0 when directional is stationary or dynamic, with a setting for each mobility)? You can also try enabling High Precision Tangent Basis and Full Precision UVs on the mesh of the ship in the mesh editor, and in Project Settings > Rendering > Optimizations…select ‘high precision normals’ for GBuffer Format.