Download

Skylight Causing odd visual errors

https://www.youtube.com/watch?v=v8dExTsolls

Whenever I enable “skylight shadows” and I fly into the my cave system this is what I get. I get this odd square that follows the camera around that doesnt render the shadow. As I move around it continues to do this, no matter what. I do not understand why this is happening. I disabled shadows but then the skylight gives improper lighting and hits edges of things it shouldnt. Any help would be much appreciated.

BACKGROUND INFO:


We are rolling with a day night system, so our skylight has to be movable, same with our lightsource (2 of them). We have created a bp that lets us control all of this, so i can turn on or off the shadows depending on the time of day.

I have played with every setting I know how and this still occurs. I can get “okay” results by just turning off skylight shadows all together, but it doesnt look as it should.

Come on, somebody has to have even a clue? This is killing me!!! :stuck_out_tongue: Last bump, but really would like to know why this is happening.

So, upon further playing with this, I noticed it is related to distance field generation. Hope this helps. I enabled the “distance fields” view and this is my result.

THIS IS THE REMOVED LANDSCAPE (square problem is gone)

THIS IS THE DFAO WITH LANDSCAPE ABOVE THE CAVE

Okay, confirmed, I removed the landscape above it and it is generating information properly, is this a bug?

Which version of the engine are you using?

4.19, and i have enabled everything related to DFAO, it only happens when I place the landscape overtop of the objects.

Well, further testing has proven it to be 100% DFAO now just to figure out why the landscape is causing the problem. Any thoughts are welcome

So, more playing and reading. I have gone through the DFAO guide, and Ray Traced DFAO, and while I know much more about it, I am still unable to figure out how or why this damn square keeps showing up.

So, in an attempt to understand further I recreated a new scene using only UE4 models and textures.
dfao_04.jpg

This only happens when I put a landscape on top of the (or above) the meshes. I can replicate this 100% of the time. Really would like to understand if I am misusing this or what.

So, went to submit a but report and found this:

are you telling me that this is never going to be fixed? I have to generate some method to work around this? wowzer!

Caused by the fact, that height field distance has the effect on global distance field all the way below the landscape.

Pull request with a potential fix: https://github.com/EpicGames/UnrealEngine/pull/4603
Probably should be toggleable.

In fact, would anyone imagine a case, when one would want to have full AO everywhere below the landscape?