Skylight can not be disabled

Create a simple scene

Add a Skylight and set the standard daylight cubemap that comes with the engine

Now make the skylight invisible with the eye-icon in the world outliner

Result: The skylight will still influence the world as before. The light has to be disabled with the “affects world” checkmark instead

Expected: The Eye-icon should deactivate the skylight in the editor like any other light. This makes applying different baked lights in multiple levels easier

Hi Wallenstein,

I’ve submitted a ticket for this. You can track the status of this here: Unreal Engine Issues and Bug Tracker (UE-36125)