Download

Skylight bug? Need help.

So basically when I hit build no matter at what quality, it seems that my skylight no longer functions or has barely any effect. All the shadows become almost solid black and the background color changed. I want to keep the previous look that I had. Any idea how to fix this? I tried pressing the recapture button within skylight, but it seems to do nothing. Its been awhile since I did a build, but somewhere along the way, maybe when i upgraded, something broke.
I also tried copy pasting everything to a new scene but that didn’t work either and had a different effect, but not one that I wanted.

In the images are the settings I used.

I’m using version 4.18.

Any idea what’s going on and how to fix it?

This is the correct result, the fog is less intense in shadowed areas because there is less light to scatter. Think of a tunnel on a foggy day in real life, when you look inside the tunnel it isn’t lit up by fog right?

If you want to keep the original result then one way to accomplish this is to just disable the volumetric fog check box.

disabling the volumetric fog checkbox won’t do it for me, it changes the look entirely and I can’t get light shafts from the directional lights.

have you tried using the height fog vs atmospheric fog ?

If what you want is fog where there shouldn’t be any. Do a depth test with a PP and stick an alpha mask over the scene color.
having it go less alpha as you get distant from camera.