Skylight artifacts

I’m currently doing an archviz environment that has both an outdoor and indoor component. I added a stationary skylight actor to improve the indirect lighting for the outdoor side, but it introduces really strange artifacts on almost all my interior walls. I’ve increased the skylight intensity to 10 to exaggerate the effect so you can see here

I have a lightmass importance volume in the level already, and these walls are very simple square plane meshes being separated from every other wall. I’m also using UE4.5 and the automatic UV import (which works great btw thanks for including this feature). Increasing lightmap resolution doesn’t really help.

Are there any solutions to this?

After some experimenting, I can get rid of 90% of the blotchiness and shadows by cranking the indirect lighting smoothness to 5+. Problem is, I lose practically all my ground contact shadows.

So I can either have clean surfaces and corners but no contact shadows, or have really bad shadowing on surfaces and in corners, but still have contact shadows.

Doesn’t seem I can find a balance to get both…

Hey JLO -

Can you upload a screenshot of your skylight and the post process settings if you have any? In particular I am interested in the settings Lower Hemisphere is Black and Cast Shadows.

Thank You

Eric Ketchum

Hey Eric, thanks for the response

I initially had the Lower Hemisphere is Black turned off. Turning it back on reduced the odd artifacts on the walls somewhat which is good.

EDIT: They’re still here!

Intensity at 1 and then at 10 to exaggerate effect

I reverted the scene’s lighting and settings back to default. No spotlights entering the windows, and default directional/skylights + world settings (except 100 indirect lighting bounces)

I should note that this effect only happens to rooms with pure indirect lighting (the directional sunlight can’t get into these rooms directly)

Hey JLO -

Turn off Cast Shadows from your Skylight and the artifacts should disappear. The Skylight should still affect world and provide an overall illumination increase in your level. If you want to have shadows in the individual rooms you should be able to add point lights based on the positioning of interior lights, your directional lighting shadows should still work as well.

Thank You

Eric Ketchum

without cast shadows illumination no good

Is your indirect lighting only coming from the skylight or do you have some white planes in front of the windows to light up those rooms as explained here

Furthermore you can try and deactivate lightmap compression. I guess this will help a lot or get rid of those artifacts but the main problem is your lighting setup to get rid of your problem in the first place. The setting for the compression is found under the world settings / lightmass options. Hope this helps…