Download

Skybox and Emmisive Materials with Cell Shading Post Process

So I recently followed Dean Ashford’s tutorial to making a post process that would apply a cell shading look to every material on the scene (https://www.youtube.com/watch?v=_bpQoI5Xrx8), and it works wonders, as warned by him, there are some drawbacks, one of those include there not being the possibility to work with Emissive.

The problem arises when I want to use a skybox, since now I can’t use anything that uses emissive, how would I go about to add a sky that worked with this post process, I tried a basic color but the post process just applies the cell shade to that and it gets a nasty look, is there any way to make something emissive keep the look, but not use emissive?

So basically the question boils down to: can you make a Skybox without using emissive? And, can you make materials that are supposed to look emissive without using the emissive node?

Here’s how it looks with the post process on (with just a basic color applied to it):

And without the post process: http://i.imgur.com/thNZy1I.png

I’d appreciate it if someone could help me out, as this is my major gripe before I can advance with my prototype.

A better solution is to use the stencil feature to only put the cel shading on certain things (with a certain stencil index). http://www.tomlooman.com/multi-color-outline-post-process-in-unreal-engine-4/
You will need to change the custom depth to use custom stencil instead.

Yes that seems to get the outline effect I had back, thanks, would you happen to know how to hide the effect when a mesh is in front of it though? So I don’t get this effect:
https://cdn.discordapp.com/attachments/272379862445064193/353107392705069067/unknown.png

if you want cel shading in the majority of your scene (strong indicator from the original post), re-rendering everything into custom stencil is hardly a better solution (performance)

I can’t open that image. I meant that you should apply the cel shading only on a specific stencil and don’t use it for the skybox.

I don’t see how this would have any effect on performance, the stencil is hardly the heavy part.

https://cdn.discordapp.com/attachments/272379862445064193/353107392705069067/unknown.png

That’s what I meant, how would I change it so the stencil doesn’t show when a mesh is in front of it?

I suspect I would have to change something here right?

The link is broken again. But yes, you can do that, see the bottom answer here: https://answers.unrealengine.com/que…-material.html
Basically just replace the CustomDepth node with the CustomStencil node or whatever it’s called and the bitmask stuff, then hook it up the same way.Or use an If node like in the answer.

That isn’t fixing the problem, I can still see the outline on a mesh when another one is in front of it, like an x-ray.

And you’re comparing the stencil depth to normal scene depth? Can you show the blueprint?

Also, what happened to the original question about the topic with the skysphere and the cel shading? The link I posted was meant as a guide for using stencils, not the highlighting stuff. If you want to use it fine I guess, but it’s another topic.

Since you can’t see the images above, here’s the Material BP:

The skybox issue is fixed, I simply changed how the emissive worked, and went through another route that allows me to use whatever skybox I want but in return it doesn’t use any emissive (so I simply put a Sky Light into the level).

Can’t you use the FillAlpha parameter in a material instance to occlude the object?

What that does is fill the area inside the lines that are drawn, so basically you see it even more, what I want is for the lines not to even appear when a mesh is in front of it.

But if you’ve got code that does something when the object is occluded you should be able to disable that further along in the BP.