Sky Light issues with mixed environments

Scene has static meshes (static), directional light (static) and sky light (static). Sky Light has SLS Scene capture. Also tried cubemap. Tried baking with all kind of quality, from Preview to Production. Tried using Lightmass Portals. No difference in the outcome.

Project was setup as mobile, with scalable quality.

Floor mesh has walls/ceiling stack upon it. Basically “indoors” floor doesn’t get any shadows from the walls/ceiling if floor mesh is not completely encased inside the walls. If even small part of the mesh sticks out, the entire floor is lit as if there are no walls/ceiling on top of it.

I tried modular meshes, a single mesh, a BSP block - same issue.

If I disable Sky Light and only use directional light - the issue goes away. Part of the floor that sticks outside the walls get “outdoors” lighting and part of the floor that is “indoors” get shadows from the walls/ceiling and looks properly.

With Sky Light (incorrect indoor lighting):

Without Sky Light (correct indoor lighting):

So far the only solution I found was to remove Sky Light and use directional light only. That results in proper lighting that doesn’t look nowhere near as good as with Sky Light (especially outdoors).

Note: Several folks linked me this A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums which has nothing to do with my issue.

Hello motorsep,

Can you reproduce your issue in a new blank project?

In order for us to determine if this is a bug or not, we need some simple steps and repro case so I can visualize the issue on my end. From looking at your screenshots, and from what I can tell in the forum post related to this issue. Your issue is project specific and requires a deeper understanding of how Skylights work.

For some further insight into Skylights and how they work, you can take a read over our documentation and the lighting troubleshooting guide. The general thing you need to keep in mind is that a Skylight is omni directional, so even if you are inside a completely closed box, the inside will still be illuminated.

Sky Lights

Lighting Troubleshooting Guide


So, looking at the docs Skylight should cast shadows, meaning it should be blocked by geometry. Even if it’s not the case, shadows cast from directional light should overpower skylight (just like walls/ceiling gets dark indoors, so should floor get dark).

Point lights are omnidirectional too, yet inside of the enclosed room will not be lit if point lights are placed outside.

The only difference between my lighting setup and FPS template lighting setup is that mine doesn’t have reflection capture sphere. So, if it’s a necessary component for Skylight to work properly, then probably it should be clearly stated in the docs (recapturing scene is mentioned, but whether or not reflection capture sphere is needed is not stated).

I’ll check that later today and post back.

There ya go - test case using FPS Template:

I opened your project and did not see anything that was a bug. The settings you had applied to your World Settings combined with the Skylight were producing expected results. Below is an example of how you can set up your scene to have dim indoor lighting still using a Skylight.

Notice how the Intensity is a 0.1 which is low. You need to realize that just because you are indoors, doesn’t mean your Skylight is going to be ignored. It provides a fill ambient light from all directions.

As you can see, the inside is still very dark and it is the Skylight that is providing the minimal visibility. There are tons of ways to get different results with your lighting. If you really have issues with the Skylight, you can set it to movable, add a trigger volume around your inside areas, and reduce its intensity upon overlap. You can also use the auto-exposure feature to help mitigate moving from darker to brighter areas, and vice versa.


Ha, that’s puzzling because this is what I get:

I am pretty limited to what tricks I can do with lighting and post processing since the project is for Gear VR.

I’ll try reducing intensity and re-baking.