Download

Sky Light causes GBuffer Decals to cast shadows?

This is a mesh that has 2 submeshes.
One has an opaque materal, and the other has a Deferred Decal/Translucent/DBuffer Translucent Normal/Default Lit material that has “Cast Raytraced Shadows” disabled.


The only light source in the scene is a sky light that’s capturing the sky atmosphere actor.
If I disable “Cast ray traced shadows” on the Sky Light, I get this.


That also happens if I enable “Cast ray traced shadows” on the Sky Light but I disable “Cast shadows” on the mesh actor in the world.

For comparision here’s the same setup, the Sky Light has its “Cast ray traced shadows” enabled, and I’ve also added a Spot Light that also casts ray traced shadows.

How can I also make the lighting from the Sky Light also ignore decal materials?