Sky dome material with transparency renders in front of volumetric clouds

In the video you can see that the stars are shining through the clouds and they become more apparent and fully visible the darker it gets

in the image is my material setup, all the online fixes relating to Fogging don’t work, those checkmarks do not do anything

Hey there @TheWeeky! This one’s a shot in the dark, but this has fixed a bunch of material issues with translucency and transparency, but I’m unfamiliar with the volumetric material portion of it. Try playing with the translucency sort policy a bit!

Is your skydome actually big enough to be behind your clouds? Because “Apply Cloud Fogging” should be all that is necessary as far as I know

Same material, no settings changed other than the scale of my star mesh:


I think its the size too
make the skydome 50,000 units larger and your volumetrics will appear