Skeletal Mesh Shadow Render Issue

Any knows the fix for skeletal mesh that is not casting shadows in MRQ?

This is my scene with rendered out with MRQ. You can see that there is no shadows appearing on the mesh behind.

This image is what it looks like after I started a new project to see if I messed up anything. Everything was stock. You can see the shadows are flipped now.

This one is from the viewport as you can see both meshes casts shadows.

I converted the one without shadows to static mesh and it casted shadows naturally. So far it is only on skeletal mesh that is having problem. All of them have physical asset.

1 Like

Are you using ray traced shadows for your directional light? If not, what is the distance for your cascade shadows? It might be that.

Yea it is RT dynamic shadows for the version on the 1st image and I even tried it with cascade on stationary lights for the 2nd image. All seemed to produced the same result.

Yeah, Im not too familiar with skeletal meshes, but I would be trying all the settings under cast shadows in the directional light and the mesh (assuming the mesh has a parent and children I’d go under those as well) is it a blueprint?

Not sure if you managed to figure this out, but I had the exact same issue and managed to fix it by increasing Maximum memory for Compute Skin Cache in the project settings. I believe it was due to being a particularly heavy mesh (~2m for me) which looks like it might be the case for you also.


You just solved my issues… 3 weeks of doing a thousand tests!
i had like 200 skeletal meshes in my scene… and it seems that after adding a certain amount (30 to be exact)… every skeletal mesh added after that was not emitting raytraced shadows (only in render, viewport looked fine)… and i was going crazy and this solved the issue!! Thanks a lot

1 Like

This worked for me. I set my Compute Skin Cache 128MB → 256MB and worked.

A few years later. But changing the “shader type” of the material fixed it for me!!! Make sure it does’nt have an opacity shader applied.

Thank you so much! I had the same problem and only this worked, did the double increase:
128MB → 256MB.

1 Like

Thanks dude… It works…

1 Like