Skeletal mesh rotates 90 degrees by itself

I’ve been experiencing a strange problem with skeletal meshes that I export from Blender. When I import, create a blueprint, and set it to simulate physics, the X axis automatically rotates by 90 degrees when the game starts. There is no visual change; the object stays in the exact same orientation on screen, but the rotation on the side panel changes to 90 degrees. This causes any components attached to the mesh to be rotated as well. This is extremely annoying when setting up a camera, since it never stays where I put it in the blueprint editor. This doesn’t happen with static meshes, only with skeletal meshes. What am I doing wrong?

I attached the blender file that I used to test this.
link text

i have the same problem…
just when i hit simulate physics…
i think it turns the bone somehow

Hi TickleForce,

This error seems fairly similar to this post:

Is that what you’ve been experiencing?

Hi TickleForce,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please respond with the requested information. Thank you!

I am also having this issue: Strange camera rotation with physics based skeletal meshes - World Creation - Epic Developer Community Forums

Did you ever figure it out?

Hi , we are experiencing exactly the same issue with UE4.8. An actor with static mesh works fine, but when I replace the static mesh with a skeletal mesh and activate physics, then the skeletal mesh gets rotated by 90°. When I disable physics OR remove the physics asset from the skeletal mesh OR keep the physics asset but remove all physical bodies from it, then it works fine again. Strange thing is also that when I set the actor rotation to 0,0,0 and print the actor rotation afterwards, it becomes 0,-90,0. I am totally out of clue here. Any ideas? Your feedback would be very much appreciated!

Hi ,

There have been some improvements on Blender’s end to the FBX exporter in blender 2.74 and 2.75 rc. I’d highly recommend using those. The bones no longer import incorrectly, however there is a new error we are looking into where animations import rotated 90 degrees. I’ve reported this as UE-17137.

Only the animations? Hmm… Is that also the reason why the skeletal mesh in the 3rd person template is rotated by 270°?

Btw. we are using Blender 2.74, but the 90° issue is still there :frowning:

Hi ,

Unfortunately UE-17137 has been marked as minor, which means it may take some time to get addressed on our end. I don’t have a timeframe of when it will be addressed.

Ok, I see, that is not so great news. Is there at least some kind of workaround you can recommend to handle that issue for now?

Unfortunately at the moment the best workaround would be to design your animations with this 90 degree rotation in mind or try the autodesk fbx converter to see if you get better results. I’m looking for a more reasonable answer, however this may take some time for me to get back to.