Skeletal Mesh partially culled in front of the camera

After importing some Skeletal Meshes and animations to my project, I had these Skeletal Meshes partially culled in front of my camera at some point of the animation.

I’m not sure if this has something to do with the camera minimum drawing distance or even if the camera is colliding itself with the mesh.

I could not find how to set the minimum camera drawing distance or change the Skeletal Mesh Collisions inside the editor.

Any ideias on how to avoid this situation?

Try moving the camera back a few cm or the arms forward a few centimeters in the components tab/viewport of the BP.

By doing this, the culling stops but since the animation was made to be played in a angle and position from the mesh, moving it would create a new problem.

Inside the editor, there’s an option in ProjectSettings->Engine->GeneralSettings : Near Clip Plane
I guess the camera manager would have it too, but not exposed.
Must explore inside the engine. I’ll report here if I find something.