Skeletal mesh is not visible in mobile preview after updating to UE4.21

Hi, I need help, I updated my project from UE4.20 to UE4.21 and some of my skeletal meshes are not visible on mobile preview now. I have tried to return the project to 4.20 but the problem is still there on that version too.

getting the same thing, haven’t found any solutions. The skeletal mesh stays invisible on device aswell.

Output log shows : Skeletal Mesh is not supported for current feature level ES2 and will not be rendered. My skeleton has 18 bones

Similar thing on PC, when effects quality level is set to anything lower than Epic, skeletal mesh disappears. No idea why this happens and why does skeletal mesh pertain to effects all of a sudden.


I too have just discovered this also. I’m working on whitebox level of my game I’m developing and everything has been working perfectly. I upgraded to v21 and only today have had a chance to do more development on it. I decided to test it on my Android device which is a Galaxy S7 and nothing! It’s like I’m playing true FPS when it’s a TPP game so all animations work such as turning left, right, jumping up and sliding down but it’s invisible. I have also placed the character in the scene just running towards me, and after disconnecting the NPC’s damage and placed it in the scene, it too is invisible. The meshes are there as I collide with them, of course, but it’s just like the invisible man! Gone! I tested it on the lower version, V20 (I even went lower again right down to V17 and working fine still), working beautifully, but for V21…invisible. Yes I have invincibility in the game and it looks funky seeing just that appear when you collect it but I didn’t want invisibility :op Like the above mine too has no where near the max bone count for mobile devices, even less than the above as mine are cartoon style characters, both player and NPC. Is there any word what on earth this could be?

Thanks guys and gals


PS: I also added 2 characters from a game I had published on Google Play recently that work perfectly in the game into this one, it too was invisible so it appears to be an issue with v21 of the engine.

Hey All,

Ok, because it’s part of my nature, and job to do, I have done some further troubleshooting. I have created a ball and jointed it. What I found is in v21 it will display the item correctly from 1 - 4 joints, 5 or more, it’s invisible. So hopefully this will assist someone further with what this could be.


Thanks for the troubleshoot. I was doing somewhat of a similar thing via blender, it is driving me nuts that in previous versions this did not happen and now all of a sudden getting this. I hope a fix will be imminent as I have already made my character and animations and I do not want to go over that procedure again as I am a beginner working alone on my first android game. I am using a plugin that is supported in 4.21 so I cannot downgrade to a lower engine version. Stuck in quite a pickle for which I feel like I cannot do anything. Please if you find a solution, kindly share.

Thank you. .

Hey, until someone chimes in with a solution as I can’t think of anything else to try, while you’re developing the game whitebox it to get the mechanics all working so for now I’d just use proxy with “dummy” animations (or “Programmer Art” as I use that all the time prior to final art assets and animations), unless you need an animation fully to test it but definitely don’t redo anything. Especially since it worked in the older versions. I’m sure a solution will present itself to this weird issue.

Exactly what I have been up to. Finishing up achievements, leaderboards and what not. Cheers!

I’ve the same problem. Some skeletal meshes are invisibile in 4.21 and others (with the same skeleton and material) are visible.

I tried to switch to OpenGL ES3.1 and then all the models are visible now, but some of my custom shaders break so it isn’t really good a solution.

Guys have the same problem I have the same problem with my version of the engine 4.21.0 I’m having the same problem. My character is always invisible.If I switch to the 4.20 engine version, is this correct?

darn same problem here… is it only 4.21? this is very annoying…

I guess the Epic received a number of bug reports regarding this topic and they should do something in the next version, because this is quite crucial.

In my case the problem is that some models have more than 4 skinned vertex in some joints. Until 4.21 the engine switched to CPU Skinning (I already noticed a heavy performance hit when using those conflicting models, but I didn’t know the cause) but with 4.21 they are invisible.

You can check the changes on USkinnedMeshComponent::CreateRenderState_Concurrent(), I compared it with 4.19 version and it’s different, and there is a new comment:

don’t silently enable CPU skinning for unsupported meshes, just do not render them, so their absence can be noticed and fixed.

I don’t remember exactly where but I saw in the code that it’s not applicable to ES3.1, that’s why if you switch from ES2 to ES3.1 those models will work, but I guess you will take a performance hit because the CPU skinning.

I tried to export one of my conflicting models from UE to Maya and changed the max influences to 4, then I reimported it to UE and it was visible on Android (but broken, because the influences from those vertex are lost).

So UE 4.21 is working as expected, the problem is with those models but we didn’t noticed until now because the silently switching to CPU skinning. The solution will be to contact the artist so they can fix them (in my case where assets from Synty Studio, if you have this problem too with their assets join us on their Discord ;D)

I facing the same issue. I’m on 4.21.1after i build the apk the skeletal mesh is hidden in game. I don’t why this is happening. Maybe there is bug.​​​

Hey guys,

I was able to find a solution to this issue by reducing the weight influence of my bones. I use blender and found out that “weight” of the bones was causing the issue and giving me the message.

“Skeletal Mesh is not supported for current feature level ES2 and will not be rendered…HasExtraBoneInfluence=true”

Initially, I had weighted the bones by USING “Automatic Weights”. Since my character is simple, it worked fine.

It is weird as in previous engine versions the same skeletal mesh used to work fine at ES2.

Anyhow, I had to go do a little bit of weight reduction for my bones inside blender, it was not ideal but I still was able to do it through trial and error.

I exported my animations, deleted my old skeleton, reimported, checked if it is rendering and then reimported the animations and set them to the re-weighted skeleton.

In my case it was a spine bone near the shoulders causing the issue.

I just want to continue as it was in 4.20. Isn’t there a way to force switch that models to CPU?

same here 4.21

Hello guys, just found out the solution for this problem, it was hard to find but implementing it easier than what i thought, only 2 click on max and done.
1-go and click on skin modifier on your mesh.
2- from advance tab set influences from 20 to 4 and export it to UE4 :slight_smile:



To edit maximum influences

  1. Select the skin object(s) whose maximum influences you want to edit.
  2. Select Skin > Edit Influences > Set Max Influences. (4)
  3. In the Set Max Influences window, set Max Influences.
  4. Click Apply to set the new value.