Skeletal mesh is not visible in mobile preview after updating to UE4.21

For Blender,

and

For anyone in the position of being unable to accommodate this change and who is also on a source build, this version of SkinnedMeshComponent.cpp will solve this issue:

https://raw.githubusercontent.com/EpicGames/UnrealEngine/af90b7bcd4205ef7a3954974a9c0fa109d2b5d34/Engine/Source/Runtime/Engine/Private/Components/SkinnedMeshComponent.cpp?token=AH22uLvZ5q41ohIpuUXcvNm0jNkMbd0Gks5cWtzxwA%3D%3D

The same in AR project, skeleton mesh with animation.

Hey Guys , your gonna love me, The new Skeletal mesh lod tool in 4.22 , has the ability to reduce the weighted mesh vertexs to 4 , simply regenerate the base lod and booom , es2 works, all without leaving the editor!

That sounds awesome but I tried it tonight and wasn’t able to get it to render in ES2 after hitting regenerate lod with Max Bones Influence set to 4 and then even setting min lod to make sure a non base lod gets chosen. I’m testing on SK_Chr_Hunter_Male_01 from Synty Polygon Western Frontier marketplace asset pack. Any ideas?

Change base lod triangle percentage to 99

It works! Thank-you!
My game crashes in UE4.22 currently so I’m reducing the bones per vertex in 4.22 and then exporting the FBX and importing it back into 4.21.
In case anyone else is trying this I wanted to share the link to the character import guide. I had to follow “Option 2: Regenerating and retargetting the skeleton” otherwise the animations wouldn’t work when I imported the character.

Thanks so much for fixing this issue!!!

Spoke too soon - the FBX export → import in 4.21 loses UV coords so textures look grey for some characters from Synty PolygonWesternFrontier, and I have no idea why. Any ideas? SK_Chr_Hunter_Male_01 works. SK_Chr_Salesman_Male_01 on the other hand is all grey because UV’s appear to have not come across in the process.

It appears the ones that fail have 3 UV channels, and the ones that work have 2 UV channels

Great…thanks.
Just changed the percentage of triangles in LOD info in skeletal mesh & regenerated LOD. That worked fine.

@ScottRyder

Thanks !!! but where can I find the picture of you list, I can’t find “Reduction Setting”

thank you I did fix mine with this solution on LOD I just lower the triangle percentage to 99 and it displays my characters now

Hey guys, I use Blender 2.79 and Im using Auto Rig Pro to rig and export to Unreal 4.22.3.

Ok, I got around the problem of the skeletal mesh not appearing in the Android build by setting the PERCENT OF TRIANGLES from 1 to 0.99 and the MAX BONES INFLUENCES from 4 to 1 like in the picture attached. Im not really sure how Max Bone Influences will affect the animations but after that, everything seems to be working normal until now, dont forget to hit SIMULATE LOD

This issue can be fixed by importing your mesh into Maya and run the attached python script: link text
Then set the max number of influences to 4 and click on the Prune Weights button. That’s it : )

THANKS so much! The Skeletal Mesh Reduction Tool, with ‘Percent of Triangles - 0.99’ works great! in 4.22. I’m so happy that I don’t have to activate ES3 or start up 3ds Max.

With further investigation it appears my issue is related to changing the material slot ID’s in 3dsmax. I can change the bone skinning around it still renders, but if I change the material slot ID’s then the mesh does not render on Oculus Quest. I am working around this by adjusting the material slot assignment in the Level Of Detail section on the skeletal mesh in Unreal. Done that way then the mesh renders on Oculus. Weeeiirrrdd

I have a humanoid skeletal mesh from 3dsmax that does not render on oculus quest. That same mesh exported directly from Daz DOES show up. I have to run it through 3dsmax to optimize and animate. But coming from 3ds max and I see nothing when ran on oculus. Neither the “Max Bones Influence”, “Percent of Triangles” in Unreal or “Bone Affect Limit” in 3dsmax 2021 appears to have any effect. 2 days in and still no mesh rendering from 3dsmax.

can you please repost this link