Skeletal Mesh is not rendering in Path Tracing UE 5.0.2. WHY?

Hello Everyone!

After carefully browsing forums, doing google search and trying to troubleshoot basic\obvious issues I am still not able to find the answer. To be hones I am pretty surprised nobody had same issue and I am looking for help, as I am desperate.

My problem is following: Path Tracer will not render skeletal mesh whatever the effort I put into it. BUT Mesh IS visible in Viewport in Path Tracing!

My mesh is very high poly car and I am supposed to use it for automotive render. It consists out of 9.5m triangles.
It is FBX file exported from Maya from the client (car manufacturer company). Than rigged in Blender.

Exported as FBX from Blender with following settings:

  • Mesh
  • Armature
  • Smoothing: Face (Apply Modifiers disabled)
  • Add Leaf Bones: Disabled
  • Bake Animation: Disabled

Imported in Unreal Engine 5.0.2 with no issues.

I have created simple scene, which doesn’t have anything in it except car and basic light setup (Sun, Skylight).
In MRQ I use default settings for Path Tracing (checked video of William Faucher on YT).
And everything is rendered except Car Mesh, no matter how hard I try and what settings I use.

What I have found out so far:

  1. Mesh appears in render with Lumen Global Illumination.
  2. If Ray Tracing is enabled for translucency - any part of mesh with translucent material on it is not rendered. (windows, headlights cover)
  3. If I split the mesh (export glass seprately for example) - glass part is rendered. But I can not split the mesh as I am using it for control rig and animations.

What I have already tried:

  1. Settings in Post Process Volume
  2. Mesh LOD Screen Size is set to 1
  3. Disabled Streaming of the world
  4. Actor is always loaded
  5. All project settings are set as needed
  6. Face orientation is CORRECT
  7. Normal are CORRECT

What could cause the issue?

  • Is there poly count limit on rendering in Path Tracer? I haven’t found anything like that in UE documentation.
  • Is there problem with Maya Export? Or specific setting?
  • UV map issue?

If anybody had the same problem please help!

I am running Windows 11, UE 5.0.2/UE 5.0.3, RTX2070Super and other PC with RTX3090.

Here are examples. You can even see the siluette of the car not rendered in Path Tracing.
(sorry, I am not allowed to show the car, so I blurred it)
Lumen GI render:

Path Tracing Render:

Hope someone already had this issue!

Wishing you all the best!

2 Likes

After running some tests, I have found out the issue of this. Basically in Path Tracing mode Unreal Engine has limitation of polygons or VRAM for render. I tried it with different models and found out that maximum number of polygons in scene is limited to around 2.5 millions. I have put models with lower polygon count to the scene and added more until one of the meshes disappeared in render. As a workaround high poly meshes can be transformed to Nanite and set fallback mesh error to 0. In that case it works fine for renders.
Also that have broken up my pipeline of using Control Rig as it uses skeletal mesh. Now I have recreated BP where I but in static meshes with Nanite enabled and it works fine, but took me one week to redo controlling setup for animation.

1 Like

I am having the exact same issue and it is driving me mad. However, I can see the vehicle it’s just the windows and shadow that cannot be seen. I am not entirely sure how to reconstruct the ctrl rig using blueprint as the model is so complex. What would your suggestion be ?

Hey there. I had absolutely the same issue with glass and shadows. So what I am suggesting to do: you can create a super simple skeletal mesh vehicle in blender, make a rig. You actually can operate the rig right through BP. In BP attach static meshes of original high-poly car to skeletal mesh in BP. Make static meshes Nanite and that should work.
Apply transparent material for your “dummy” car and that’s it. Hope I made it clear!
Good luck!

1 Like

Thank you for sharing your fixes for this issue, it’s the only information I’ve found on the subject. I’m having the same issue with a large crowd of skeletal meshes. I was wondering if you or anyone else had any ideas for how I could fix this problem - oddly enough, a group of the skeletal meshes is rendering properly but the rest are not. There are about 400 in total and about 150 of them are rendering. I was thinking I could replace some of them which don’t need to be animated with static meshes and convert them to Nanite like you described, but if anyone has a more efficient solution or a recommendation for my particular situation I would be very grateful!

Had a similar issue. I found out that “Visible in Ray Tracing” was marked as False; in Details section of the StaticMeshActor. When i set it to True, the mesh appeared in Path Tracing view. I use UE5.1.

Hope it helps anyone.

After Crying in the shower for hours and testing a bunch of stuff, I set the Maximum memory for Compute Skin Cache per world (MB) to 4000. The default is 128. I set it high just to be sure but it worked for me. my skeletal rigs and control rigs started rendering.

I hope this helps someone, Godspeed!

11 Likes

I did the same! (crying in the shower) and just invented my own rig without bones so I can use nanite and suitable for animation… But you. You are a legend. Thank you so much!

1 Like