Skeletal Mesh import issues 4.5

I’ve been looking for a solution to this problem for 2 days now without results. Here’s the issue.I imported an FBX file with animation included. The file imported fine and the animation too. Everything worked fine until I decided to click off the “Import mesh” option. Now when I try to import a skeletal mesh the “Import Mesh” options is gone and there is only “skeletal mesh”. I clicked it and when I get to the import animation window the “Import All” is grayed out and I can’t import skeletal meshes or animations anymore. I tried to reset the importer to default but I can’t find where to do that.

If anyone is having this issue and know how to solve it please post how to solve it. Again the “Import Mesh” options in the FBX import is gone and I can’t find it.

I’m having the exact same issue! :frowning:

Hi Raf1983,

I’ve been trying to reproduce this issue in UE4.5.1 with the following steps:

  1. Initially import FBX with animation:


  1. Then try importing another FBX with “mesh” un-checked, but then import options become unavailable:


  1. Re-check Import mesh and Import options become available again:


I’ve retried this several times with different fbx files but have been unable to reproduce your issue. If I’m not following the proper steps, please advise how I can better reproduce your situation.

Also, what environment are you working in (Windows or Mac)? What are your system specs? Does this happen with new or existing projects. Any additional information you can provide will help us troubleshoot this better on our end.


Yes I forgot to specify That I’m using windows in a bootcamped Macbook pro. I’m running windows 7. The project that I’m working on was created in 4.4. when I installed 4.5 and It created a backup copy of the project. I’ve been working on the project ever since. The FBX file was created in MAYA 2014 using fbx file format 2013. I imported the FBX with Skeletal mesh and animation and it uploaded fine but since I was doing two different cycles I just wanted to import the animation and not a second mesh. That’s when I decided to click off the import mesh and just bring the animation. But now I need to import a new mesh with a new animation but the “mesh import” is gone from the options.

I believe I found the solution to the problem. My model was rigged using icons and SDK’s to drive the animation and UE4 recognized it as a static mesh instead of a skeletal mesh. I made a simple arm joint system with a cylinder and the “mesh Import” showed back up. The only strange thing is that I was able to import the mesh and animation into UE4 with no issues prior all this with the same FBX file. Hope anyone that had this issue found this helpful.

I was having difficulty reproducing the issue but I’m glad you were able to resolve it yourself. Please feel free to add to this post if you run into any more glitches related to this!


There’s definitely still a bug here, but I’ve found a workaround that may shed some light on things. I’m hoping epic can replicate the issue with the following info, but maybe it will help others who encounter the issue. This is a very common way to animate weapons!

  • Use parent/child relationships to rig
    some geometry in Maya, give it some
    basic animation.
  • Export geometry to FBX (with
    animation ticked on).
  • Import FBX, check on “skeletal mesh”
    but also uncheck “import mesh”
    along with “import animations”.
  • A skeletal mesh will be imported
  • Import the same FBX again and the
    “import mesh” option will have
    disappeared, along with some of the
    animation import options such as
    “animation name”. Showstopping bug!
  • This seems to occurs even if you
    import the 2nd time to a different
    folder, or in a new editor session
    once you have unchecked “import

The workaround I’ve found is that importing an FBX that has skinned (to joints) geometry just once will reset/fix import options on parent/child animated FBX files. Unfortunately, it breaks again the very next time “import mesh” is ticked off, during any import at all (even one that is cancelled).

I first thought the engine had a problem converting mesh parent/child relationships to bone hierarchies, but it actually works just fine on first import (until you want to bring in animations) and with the above workaround.

There was a known bug importing certain FBX files that was addressed for the 4.6 preview. Are you able to download this version and if so, are you still experiencing this issue?

I’ve had the opportunity to grab 4.6 preview today and unfortunately the behaviour described above is still present.

Hi BobJoel,

Thank you for your detailed reproduction steps. I finally got a chance to reproduce this problem and have generated the following bug report: [UE-5953]. It is unclear at this point if this was intentionally designed this way, but I have explained that this impedes a common workflow and have requested a change be made.

If this is resolved in a future release of the engine, an update will be posted to this thread. Thanks again for your feedback!

I experience this selfsame problem, yet I am unable to implement the workaround detailed by BobJoel.

My attempt:
I create a short bone chain in max, skin a cylinder to it, export to FBX, and attempt to import to UE4. Still no import mesh checkbox reveals itself. What gives?

Update: I managed to conjure up the “import mesh” box by re-importing (actually dragging it in anew, not using the re-import button) an old skeletal mesh i had in the scene. This seemed to make the menu amenable to importing meshes again.

This bug is still being looked at. However, when I was retesting yesterday I discovered the cause is due to the original skeleton being kept in the editor even if deleted in the Content Browser. Hence, when you go to re-import your mesh it still tries to apply it to the original imported skeleton.

This bug does not seem to happen, however, if you do not uncheck “Import Mesh” upon the original import. In other words, if you include “Import Mesh” the first time, you can re-import an updated skeletal mesh again and again without experiencing this bug. That was what I was able to do while testing here. -Try this solution and let me know if that is not the case for you.


I understand this is a fairly old thread, but I would like to point out that this issue (or a very similar issue) still persists on 4.7.6(-2513093, if that’s relevant) and that it appears to be an issue with the project and not the .fbx file. At least that’s what I assume as loading up a clean project restores the normal functionality of the importer.

Now to clarify the issue as mine appears to be slightly different but very similar so I wouldn’t really call this a separate bug. When I press ‘import as skeletal’ everything in the ‘Mesh’ section disappears besides the skeleton option and the import buttons are then greyed out. It doesn’t matter what is in the .fbx file, as a mesh by itself, and a mesh with an armature both do the same thing.

Hi DeathPickle,

Did you try the workaround I posted Jan 20, 2015:

“This bug does not seem to happen, however, if you do not uncheck “Import Mesh” upon the original import. In other words, if you include “Import Mesh” the first time, you can re-import an updated skeletal mesh again and again without experiencing this bug.” -Let me know if this does or does not work for you.


The issue is still happening for me in 4.7.6. on Windows 8 despite the above workaround.

In my case, everything works fine until I try to import an FBX file with only joints or nulls from Maya (but with no actual polygonal geometry) as a skeleton. Once this happens, the Mesh options permanently disappear in the FBX Import Options dialog when the “Import as Skeletal” option is checked. As stated earlier in this thread, I too am unable to recover these options even after restarting the editor.

Per DeathPickle’s suggestion, I too fixed my issue by rebuilding the project. This wasn’t too terrible as I simply created a new empty project and copied everything from the old one into it, then I just needed to set up a few things again (World Settings, etc.). Annoying, but not terribly painful compared to the prior inability to import anything as a skeletal mesh.

I agree that this definitely points to some left-over reference in the project as the culprit just as DeathPickle and both mentioned earlier, though I tried removing/replacing every single file in the previous project to no avail. Either I missed one, or it’s some embedded configuration setting somewhere.

Just had this happen to me again and decided to dig around a little more. Turns out there are at least three other threads discussing this same problem, and one of them has two workarounds listed that are significantly less work than rebuilding the entire project. The first one listed below worked in my case…

from Straycodemonkey:

…What did work was editing EditorUserSettings.ini within the project concerned and setting bImportMesh=False (yes, False). Next time the Import Dialog opens the Import Mesh options will then be visible. Hope that helps until the bug is resolved.

and from Tearl:

Find your EngineUserSettings.ini in the /Intermediate/Config/CoalescedSouceConfigs folder. Under the heading [/Script/UnrealEd.FbxImportUI] Set bImportRigidMesh=True Restart and import again. I noticed the ini will re-write this value to false, but at least the dialogue worked correctly.

This problem was also mentioned in the following threads:

According to Tim Hobson, this bug has been fixed in 4.8, but for those of us who haven’t upgraded yet maybe this will come in handy.