Download

Skeletal Mesh Flickering

Hey guys,

I have tried to put my own skeletal mesh (3dsmax -> FBX 2013) in to replace the current one in the third person template. The trouble is that the mesh flickers and dissappears when I move the camera around.

Does anybody have any ideas why this would happen?

Thanks.

A video from the problem + a picture from your material setup will help us to solve your problem :slight_smile: Does this flickering also appears when you just place the mesh into your level?

Video would help but as a rule of thumb if an object flickers it’s usually an indication you have some type of Z-buffer fighting going one.

Usually this occurs when you have two objects sharing the same space and the faces of the object fighting over who gets rendered first and sometimes can result in an object not being rendered at all.

Since it is a player model one could assume that you don’t have a LOD set up properly.

Can you open your skeletal mesh up in the editor and turn on Show Bounds? It sounds like the bounds are incorrect or tiny, causing the mesh to get culled as it animates.

Cheers,
Michael Noland

I am having a similar issue

I have looked at all the items mentioned above and see no differences in this skeletal mesh to another.

I am going to back to the model before export and confirm there isn’t a duplicated mesh by chance, done and no faces inside of faces or anything hidden.

The LOD is the same as any other skeleton mesh I have

The yellow bounds seem the same size as any other of our character models

As Michael says this sounds like a bounds problem - we use them to determine if we should draw the mesh or not. Do you have a PhysicsAsset assigned to your mesh? That is what we use to calculate the mesh bounds as it animates.

ooh I getcha and yes those where created the first time I imported the skel mesh. However we have been just replacing the mesh over and over as we make changes to the weight paint etc.

I will delete the physics asset when i get home and the skel mesh re-import and see if that solves it.

Solved my problem - physics asset deletion and deleting the skel mesh and re-importing / creating them

Disappointingly, this did not work for me.

The bounds were a little large so I ammended with a Physics Assets as you mentioned. The flickering still occurred.

I managed to figure out how to get ShadowPlay to work so here is a video on a very awful test mesh I made.

https://youtube.com/watch?v=bsZzDfdgtLI

Sorry guys, don’t mean to bump a thread but I really need help with this.

Could you probably share your files so that we could take a look at it? :slight_smile:

Every model I try to import with this rig and set up causes the same issue, I will upload the file for you.

EDIT:
Heres a link to the 3dsmax file with the RIG

No matter what I try. I can not figure out why this happens :frowning:

Hmm, pretty strange. I have imported the char - added it to the third person bp but somehow in my case it isn’t flickering :confused:

Could you probably post your PC specs?

Try it out with those files: test_char.rar - Google Drive

Strange, it did it even with your files :(.

It works fine with the basic HeroTPP Mesh though.

My graphics card is (don’t see how any other component would cause this):
Geforce GTX 760 with latest drivers (337.50)

I decided to have a look at the Blueprint again. I made some changes to start to get things working. Turns out they caused the flicker.

Sorry for the confusion, but you can now consider this fixed!

Happy faces all round. :slight_smile:

hi paulv2k4, could you please tell us what the fault was, just in case someone does the same and can find a solution
cheers

Hi. I can not remember exactly what I deleted. It was along the lines of setting the physics asset in the blueprint, which I assume would cause the bounds issue as it was setting the incorrect PhysicsAsset and then trying to simulate physics.

Sorry for the confusion. I feel a little stupid, ha.

You sir are a life saver!

I’m working on a global game jam and using oculus, the flickering mesh was the most headache inducing thing on earth.

I’m having this issue with a skeletal mesh as well, but I haven’t touched the blueprints on my level so far. It’s only happening after I export the mesh from Unreal, delete the old one, then import it again. I’m doing this to solve an issue with the physics asset that unreal generates for it, the first one is much too big, and it’s impossible to approach the mesh in game, but when exported then imported, it makes a correct physics asset, but the mesh blinks. I looked at the show bounds in the editor, but I’m not sure what I should be looking for. There’s a blue box around the whole thing, and a yellow sphere around the blue box.