Skeletal Mesh Disappears or can't move

Hey guys,
I have a problem while playing skeletal mesh animations with a matinee. I’m making a side scroller game and I introduce it with a matinee.

I could only see my skeletal when I play in the matinee. If I play in the viewport my skeletal mesh is invisible, but I still see through all the matinee cameras. When the matinee ends, the game starts and everything works fine. I see the character and I can move it. I’ve tried making a new physic asset following the tutorials, and I’ve tried to increase the bound scale, but it doesn’t work. The only solution I’ve found is to set Mesh Component Update Flag to Always Tick Pose and Refresh Bones.

But when I set it, I can’t move the character when the game starts. I can still trigger some animations like when the character throw his head.
I couldn’t trigger the jump animation, but when I set the Root Motion Mode to Root Motion from Everything in the animation blueprint, I can trigger the animation, but the root stays in place. I can’t trigger the run animation, but when I press WASD, the character turns to the direction I want to go. The idle animation still plays.

To sum up, when the Mesh Component Update Flag is set to Always Tick Pose, the skeletal mesh is invisible only during the matinee, and when the game starts the character is visible and moves.
When the Mesh Component Update Flag is set to Always Tick Pose and Refresh Bones, the skeletal mesh is visible during the matinee, and when the game starts, the character is still visible but can’t move.

I’ve tried a cheap solution: Having the same skeletal mesh twice, but with two different names. One for the game, and one for the matinee parts. For some reasons, when the SK for the matinee is set to Always Tick Pose and Refresh Bones, and the SK for the game is set to Always Tick Pose. I get the same problem as above, just like it was the same skeletal mesh

Here is a Video

Here are screenshots of how I set up the Event Begin Play in the Level Blueprint:

Here is my skeletal hierarchy:

Thanks for your help! :slight_smile:

Hey Didie9,

You seem to be controlling a lot in blueprints that is actually controllable through the Matinee Actor itself. Using the matinee actor instead of blueprint logic is probably going to resolve the issue you are experiencing.

I have created a Side Scroller project as a test example on how I set this up on my end. Notice in the cinematic section there are also options for character visibility and inputs. With this set up, I didn’t have to use any blueprint logic, and was able to view the matinee as soon as I pressed play, and the blueprint character remained visible.

Matinee Control

Try out my set up and if you are still experiencing issues please let me know.

Cheers,

Andrew Hurley

Great! You just solved my problem, now it works perfectly! Thank you, I really appreciate!