Single Line Trace does not always hit the Object (Landscape)

I’m trying to get the location where the trace hit the landscape.

Unfortunately on some locations, the trace doesnt hit the landscape and is just going through it.
The camera is below the landscape, that’s why it seems to be invisible in the image below.

It just happens on some locations, mostly it works. It’s not random, if it works once it always works, and if it’s going trough on some location, it always does.
The Landscape is the only object which is blocking the Terrain Trace Channel.

I have the same issue. There is a lot of randomness to the problem, but it almost always misses at 0 on the X axis in world space. My traces are going straight down.

As someone suggested on your forum thread, I’ll try using a shape trace instead.

I use a sphere trace with a radius of 10, that works.

Hi everyone,

I was able to reproduce this and have entered a bug report, UE-11871 to be assessed by the development staff.

Haha, I asked it 4 months ago and now finally you enter a bug report :wink: Well, it’s not a very critical bug since it’s very easy to work around.

How do you workaround this?

Just use a sphere trace with a radius of 10 :slight_smile:

Have same problem

Seems like they still not fix it.

i found that problem today, still not fix… works with sphere trace

Observed the same bug today. Is there an update available on UE-11871?

Hi Tynril,

This bug is still under assessment by the development staff. Unfortunately, I do not have a timeframe of when a fix will be made available. I have updated the bug report to reflect that more developers are experiencing this error.

This happens on very very large chunks on Flat Landscapes Parts. The general Area where it happens in my case stays consistent but gets larger or smaller depending on the Offset on the Z Axis. Hope this information is of any help here a screenshot that showcases the Misses on a grid.

Thank you for the updated information, !

Have the same problem with 4.12.5

Problem only appears with a Landscape as hit target. It usually hits but randomly misses.

Workaround by SphereTraceByChannel with a radius > 0

Hi JulianS,

Thank you for the update. This error is still unresolved, and can be viewed here.

it seems not only occur on landscape, because i put a cube under the landscape, when the line trace through it(no hit occur), the line trace doesn’t hit the cube either.
But the character can be hit by the line trace.

This also affects Boxtrace on 4.19

Might just help someone, but a solution on another thread was that traces that start and end at the same coordinates will fail on landscapes. make your start/end just one unit away from each other.

This worked for me, 2 years later. What an insane thing!