Download

Show Particles (Cascade or Niagara) only on Render Texture Target not in Main Camera

Hi,

dose anybody happen to know, how I can hide particles form my main camera, having them only render to a texture target? I have a working setup for all other objects:

  • I set the owner of an actor to the player via blueprint
  • check in each the objects “owner no see”
  • add the objects to the “show only” list of the scene capture camera, that captures the render texture

But this does not seem to work for particles at all, they are still drawn in the main camera view. Do I have to set each particles owner, is there a way for this? Or must each particle be in the show only list of the camera, and if so how would this be done?

I’m also interested on this.

If you create the particles in your player BP the option “owner no see” will works, at least in my case. the problem is, what happen if you unpossess your player. Then all particles become visible, so yes, there should be another solution different from owner no see.