Shared texture sample not working?

So, I made a huge landscape material a while back whit 4x4 texture atlases and 5 maps for each material layer within it. It always worked great but now that the shared assets feature have been released as of 4.6 I figured I might as well dismantle my atlases and rid myself of some instructions by just using shared assets instead. However, as soon I try this, landscape components turn default gray checker material like it used to when too many texture samples were used.

Any idea what I might be doing wrong? All textures are set to Shared: Wrap, also the project is set to use DX11.

I’m trying to do the same thing, but it’s not fixing my gray checkered spots on my landscape either. I’m still searching myself, so if I find a fix I will post it here to help.

At least I’m not alone. Hopefully someone can shed some light on this.

For some reason, when I unplugg roughness the problem goes away. I can’t use material layers with roughness anymore. Any ideas?

Double check your textures to see whether they are using the Wrap or Clamp method for tiling, just double click on the texture, then check the advanced options in the Texture section of the details panel. If it is set to clamp you will need to switch the shared sampler method in the material.

Thanks for trying to help! It was something similar. I had failed to set one of my texture samples that isn’t using SRGB, to linear color. Strangely enough I didn’t get any errors, it just didn’t work. Works great now though.

I can’t tell from the descriptions what’s going on here, but you can tell if the Shared sampler settings are working by opening the stats window in the material editor and watching the ‘texture samplers’ count. If you have two TextureSample nodes both using SamplerSource = Shared: Wrap, they will only add one ‘texture sampler’ to that number, whereas before that would always use two ‘texture samplers’.

Hi, i am new to Unreal Engine 4. I am working with Unreal Engine 4.11.2. I came across an issue where I am not able to use 5 maps per layer on just 3 layers. I am using Albedo, Roughness, Normal, Ambient Occlusion, and Height on all 3 landscape layers. The problem is, the Shader renders the grey checkerboard texture instead of my landscape materials. Is there any work around in 4.11?