Download

Shadows way too dark despite SkyLight

Hi everyone and happy new year :smiley:

Here is a simple scene:http://i.imgur.com/JniFwBdm.jpg

As you can see shadows are way too dark, despite the fact I have a skylight in my world. here is the light and skylight settings:
http://i.imgur.com/Ah7XE09m.png
http://i.imgur.com/4IiI5Sqm.png
What is strange is that yesterday it was working perfectly fine. i already had this issue on another map where sometimes shadows would be OK sometimes not. Using 4.9 engine with Nvidia GameWorks.

Any idea?

Thanks in advance guys

Your shaders aren’t compiled yet. Wait for them to compile and then see if it works.

It did solve the issue, but it’s weird though because when the shaders aren’t compiled yet, the engine put a default shader which should work. Also, I toolk the screenshot after making changes to the materil, but even before it did not worked.

There are more shaders than just the material shaders: https://github.com/EpicGames/UnrealEngine/tree/release/Engine/Shaders

What was probably missing in your case was the skylight shader. The engine has to recompile them if you change some project settings (like enabling accurate vertex deformation velocity or distance fields).