Download

Shadows too soft. How to make darker?

Hey, I am noticing the shadows are too soft. I like the current lighting but need the shadows to be darker. I remember in UDK you could control shadow intensity but I don’t see an option for that here. Just shadow color which is already black.

Also, I’m running into an issue with the shadows / lighting breaking on level reload. If I start the game, the shadows are there. When I die and the map reloads, the lighting is slighting different and the shadows are gone.

Edit: Just in case someone asks, the shadows on the mountains are baked into the image itself so those aren’t going anywhere. It’s the shadow for the ship I’m having an issue with.

Lighting/shadows on start:

Lighting/shadows after dying and reloading map.

What are your light settings? ( skylight / direcitonal / moveable or what? )

And what intensity are they set to.

You can also control shadow darkness and contrast with a post process, but that’s not gonna save this.

There’s a single stationary directional light in the scene with default settings. No skylight, reflections, or sky sphere. It’s basically a 2.5D scene. The only 3D objects are the rocket and the ground, which is only large enough to fit the camera. The clouds, background, and sky are all planes layered to give a pseudo 3D impression. I’m trying to keep the game light for mobile. World lightmass settings are default as well.

I tried adding back in the sky sphere, reflections, sky light, and even a lightmass importance volume but the problem remained so they were removed again.

Capture3.PNG

Edit:
Just tried creating an default map. The same problem occurs; if playing from startup, shadows are there. If the map is reloaded while the game is already running, the shadows disappear. I tested this as well on an empty project and it does not happen there.

Default map on startup

Default map on reload

Whatever it is, it has to be a setting somewhere.

The Skylight typically is where you’re able to fix that, did you try?

Yes. Shadows still disappear when level reloads.

I’m still having this problem where the shadows disappear when a level reloads. It doesn’t happen in a new project so it’s obviously some sort of project setting I just don’t know which it could be. I’ve tried going through and comparing my project’s settings to a new project’s settings and world settings but I can’t seem to solve it or replicate it on another project.

If it is a project setting, the only thing I can recommend is looking at the actual config files. They’re in ProjectName/Config, outside of the UE environement. It’s much easier to compare them.

Couldn’t find it. Ultimately I did a rebuild. Essentially, I deleted these folders:

.VS
Binaries
Build
Intermediate
Saved

Then did auto-rebuild. Whatever settings I had previously were wiped. I don’t know what that setting was that broke the shadows, but it’s gone now and the shadows are working as they should.

If anyone is curious, the guide for that is here: https://www.multipainkiller-studio.one/dev-tips-for-game-developers/fixing-corrupted-unreal-engine-projects-files/

Make sure eye adaptation is off, then darken the skylight. The only way to make shadows darker is to have less light in the scene or deacreasy all the post proccesing stuff.