Shadows too reflective of sky?? (translucent plane with planar reflection)

Hi, I’m testing out a translucent plane that’s supposed to be frozen water/ice that’s reflective. Underneath the plane, is another plane that is completely opaque. The lights cast shadows through the ice plane and onto the plane below, and you can see the shadows though the ice and if you go underneath the ice as well. This part works as it should with the default Skybox with color changed. No problems.

But, I tried creating a custom skybox and followed a tutorial, and while the custom skybox did work, it cause problems with the ways shadow were displayed. When standing on the ice now , the areas where whe cast shadows below the ice’s surface can be seen, the shadows simply reflect the skybox too much, and completely overshadow all the other objects in the scene. In fact, when standing on the ice, it almost looks like the shadows are HOLES.

But if I go underneath the ice’s surface (the translucent plane) the shadows look relatively correct.

A few things I tried to remedy this:
1.Tried deleted the planar reflection. This did NOT work. Still the shadow problem
2.Tried changing the translucent ice to alpha-composite ice. Still the shadow problem
3…Tried switching back to the original default skybox (instead of the custom one). This fixed the shadows… until… I increased the “sky distance threshold” of the skylight by a lot. This caused the same shadow problem again. But LOWERING the “sky distance threshold” a lot fixed the shadow problem… somewhat, by making the shadows a lot lighter.

So, what do you think could be the source of the shadow problems?
How would I fix it?

If it helps at all, I’m using the Unreal Engine version 4.20 with the forward renderer enabled.

Here is the Ice material

Basically, how would I make the reflections of the skybox more “dull” where cast shadows from underneath the surface (shadows cast on the opaque plane below ice can be seen (make the cast shadow areas a lot less reflective of the skybox)?

If it helps at all, I’m using the Unreal Engine version 4.20 with the forward renderer enabled.