Download

Shadows on Foliage broken with Ray Tracing?

I’m finding that casting shadows (with a Directional light, in UE4.26) using Ray Tracing works properly with normal Static Meshes, but not with Foliage. It’s not that it *never *works, because on some meshes the shadows keep on popping up and disappearing - leading me to think it has something to do with the distance calculation.

  • Setting “r.RayTracing.InstancedStaticMeshes.Culling 0” (as suggested <here>) doesn’t seem to have any effect
  • I don’t think the problem is in the materials or the mesh itself, since RT works fine on the Static Mesh
  • I’ve tried changing various Foliage lighting settings, but so far without success

Here’s a screenshot of the result:

  • Left image has Ray Tracing Shadows disabled, Right image has them enabled
  • Left tree is created by Foliage, right tree is a regular static mesh.

You can see the improved quality of Ray Tracing here - but of course the shadow is completely missing for Foliage. Strangely, the self-shadowing does work though

Does anyone else have this issue? Any solutions?

This is a issue I have been facing too. @Warner_V were you able to find any solution to this? Thanks

A solution, not yet… However, the explanation is that foliage is not yet (fully) supported by Ray Tracing. As workaround you can either:

  • Put trees in the level as regular assets
  • Use a specific NVIDIA build of UE4 that does support foliage (assuming you’re using NVIDIA equipment)
  • Switch of ray-traced shadows in your (sun) light