Download

Shadows not working as expected on a specific model

Hello everyone,

I’m working on a small scene with four dynamic spotlights. One of my models is a cabinet and uses a two sided material in its first slot for the main color and a translucent in the second one for glass. For some reason once a place the model on the wall or floor it looks like it doesn’t have any background, the shadow appears only in the borders, but the center remains illuminated. I checked on the “Shadow two sided” checkbox under lightning but it doesn’t make a difference. I also tried by making outer and inner faces for the model to see if it was a problem of the model itself but still get the same result. Any ideas on what I might be doing wrong? Engine Scalability Settings are set on “Epic” and also tried by changing the lightning quality to “production”, it doesn’t make any difference. Thanks in advance!

Try enabling, in the mesh details panel, “Volumetric Translucent Shadow”. It may or may not work. The issue appears to be the glass somehow creating a lit area through the solid part of the mesh (bottom/back part). Is the glass refractive (is it using refraction input in material with any nodes attached to it)? If so, how is it set up?

I’ve encountered a similar issue in a test project. I created a refraction-based glass, applied to a sphere in the scene, and a few opaque objects behind the sphere are getting reflected with translucency and offset due to refraction. So I’m actually able to see through those opaque objects’ reflections in the sphere, causing them to blend with a green wall behind those objects. The refraction in the glass material is simple. It lerps between a scalar parameter for front refraction and a scalar for side refraction, with an alpha of fresnel having a scalar for power (strength of the fresnel effect). I tried two-sided in the material, and disabling it, and it doesn’t work.

I think that the glass material placed in the second material slot is not rendering correct sort priority for translucency and what is behind it. That is an essential aspect of translucency, with the higher number getting sort priority from front to back. If the sort priority values are all the same (e.g., the red opaque part of the cabinet is a priority of 0 and the glass is a priority of 0), then it renders from back-to-front. Since that includes the shadow, it’s as if the glass is not having a shadow rendered, yet that is projected to behind the opaque part of the mesh. This is probably making it confusing. Look up a video or two about translucency sort priority on youtube. And read the doc page on translucency. It’s probably going to require a really specific setup in the glass material to function correctly in a mesh with two materials.