Shadows mess up after building

Hi guys, I am still learning UE4 and working now my first UE4 game in 4.16 version, but when I put everything looks great, and after building light it changes drastically to bad. Why is this happening? This is one example in bottom image, on top is before building light and on bottom after building, I got this weird shadow spot all over my objects and etc.


Your lightmap resolution is too low

Thank you, will change that. What is best option to put? And I got this errors in log, just googling and doing research how to fix them, its easier when I know what is the problem:


Now when I go inside mesh to change UV it doesn’t allow me, always get back to 0 and not accepting 1 as I want, even when I try to Change in Lightmap coordinate index from 0 to 1 it automatically switch immediately to 0. I see that is problem that many people got, but noone post solution :S

In your 3D app before you export to UE4 you need to create a second UV channel for your lightmap: Unwrapping UVs for Lightmaps | Unreal Engine Documentation

When you then import to UE4 you need to uncheck the option Automatic Lightmap Generation, it will then use the UV channel that you made for your lightmap. If it doesn’t allow you to change the lightmap coordinate index then you don’t have another UV channel to change it to.

Yes I import everything again and now I can switch between 0 and 1 UV lightmap so there is no more overlapping, but now after building light I got this one, you know what should I look for about this problem. Btw thanks a lot for help:

Not a big issue, it’s just a volume (a box) that defines the area where it should focus the high quality lighting calculations so that it doesn’t waste time on areas that aren’t important, you can create one from the Volumes objects.