Download

Shadows issue

Doing the level design tutorial and having some weird issues with the shadows. Tried changing the lightmap from 32 to 128, nothing. From preview to production quality, nothing.

Current lighting is:

Several WallSconce
A CeilingLight
BP_Sky_Sphere_C4857
A SkyLight
A Directional Light

Pre-bake:

a2ce1058104e5e4b6f58a175ac2c498be0bf5269.jpeg

Post-bake:

e87b1fdb05701ae77a9bcd99f59520149d4b061d.jpeg

Any ideas why?

Yep, resolution is too low. You can change the setting on the static mesh in the content browser or select the static mesh in the scene and change the lightmap resolution override setting in its properties.

Upped to 512, nothing noticeable. Must be something else

Is there a way to change the lightmap on every single object in the scene?

Try setting it to 4, take a screenshot and compare it with one at 64.

On BSP you need to LOWER the number to get better results rather than increase it, on static mesh you are setting the size of the light map.

Yup, setting to 4 kinda solved it for BSP. Can someone explain the logic of why BSP need to be low and SM need to be high?

I think it originates from the idea that 4 = each shadow pixel is 4 world units (Not likely the actual case, but that’s the concept). Since BSP can be moved and scaled about in the engine, you’d want to maintain the texel density. This way, you can adjust all your variously sized bsps to a uniform lightmap density, even having different densities per-face. Whereas static meshes are a specific texture resolution. It’s a bit confusing, but tends to work out. I do wish you could set a world-text resolution for static meshes and the engine could figure out the resolution automagically.

Agreed. I’ve been creating a dynamic material instance, and setting the UV coords, but it really seems like there should be that ability within the mesh.