Download

Shadows in unreal acting weird

So i have this model i made myself in 3ds max, it has light map. The lightmass res is good etc. etc.
Now i also have this other model wich i dident make. On that the shadows are nice clean and all around good, although on the first model it looks like ****.
(All of this can be seen in the video below)
Does anyone have any clue how to fix thise shadows, its driving me insane!!!
Been trying to fix this for a week now.

I have the feeling that you have overlapped uvs or your uv islands go outside the 0-1 uv space. Can you show a picture of your uvs - second channel?

I have tried several things but this is the method most youtube tutorials suggest you.
But i have also tried with plannar mapping each site, right now im trying from maya to UE4 to see if that changes anything.
589a214da5f551ce5add353f28479b83dd77a29e.jpeg

If you upload as fbx/obj and i can take a look if you want. I think it will be a combination of lightmap size and islands in the UV’s.

Hmm, can you take a screenshot with a Alt + 0 mode on (just press the key combination) to go back to normal mode alt + 4.

Your lightmap resolution is too low. Also, your Uvs are not very good–you used an automatic method which creates too many UV islands which will require a high lightmap resolution to get good results. Also, it looks as though you have some surfaces like caps on your walls which are not necessary and should be deleted.
For interiors you should separate out by parts–so ideally you can do the walls as one object, floor, ceiling, etc. rather than all of it together.

Do you guys have any tutorials i could follow?
I feel its hard for me to really understand how lightmaps should be layed out…
Is it just like normal uv map or should i have every thing seperated?
Also all of the walls are one model but the roof and floor is not a part of that mesh.
Maby you guys know a good tutorial that shows the correct way of doing it.
I dont know how to attach the 3d model into the forum chat :I

Here the screenshot with Alt+0
8d6e61438d293f8a220ce7fb9b33a15107843fca.jpeg

I think i already tried the method you are talking about wheres every side of the model has a planar map as seen below (Confirm/Deconfirm)
06ccc8d070838b1e5e32d80b2cdcf1f93de650db.jpeg

Or would this uv map be better (just made it)?
37334813b5ef8f3e9b4fe5688375ded4673c6cae.jpeg

The resolution needs to be higher, each pixel in the Alt+0 view is a pixel on the light map, you probably need x16 or x32 the current resolution.

Is it within UE4 or in 3DS Max you want me to change this, I have already changed this option in UE4 but it dosent seem to do any difference…

klip.JPG

Min Lightmap resolution doesn’t change the light map resolution it bakes at, just the minimum resolution that gets used when viewing an asset from further away. There’s a separate setting called “Light Map Resolution” in the static mesh editor, and there’s also an override light map resolution setting on the details panel.

Hey guys, i just increased the res for the objects as seen and all the ****** shadows are now gone after redoing uv and some settings.
Thanks for the great support! :slight_smile:

As I suspected that it was low rez on the lightmaps. Alt+0 is good way to troubleshoot bad lightmaps, sometimes you can see that the uv is not that “flat” that you think it is. For the UV layout, the less space the uv islands cover the bigger resolution you will need to bake nice shadows. Also the bigger is the resolution, the longer UE4 will bake the light. I think its a bad practice that a lot peoples do to have all the walls inside one uv space. The best way (tho its a little bit time consuming) is to detach all the walls faces and apply uvs on them, this way you will get very dense lightmaps on lower resolution. :slight_smile: