Download

Shadows for distant objects.

Hi

With distant landscape , the objects cast dynamic shadows, is it not possible to use lightmaps only for shadows as i`d thought that was more efficient if you dont get close to these objects. I can only seem to turn shadows on/off.
Any way around this?

Thanks

Any ideas? thanks

Have you tried using the Far Shadows option in the light source. You can tick this for static meshes, landscape, etc in the details panel to enable them to use far shadows as well. There is still a limitation on how far a dynamic shadow will cast though. This just extends it a bit to give you more play.

If that doesn’t work have you looked at Ray Traced Distance Field Soft Shadows?

Thanks. I tried the far shadows but I couldnt find any option in the foliage for it. You can change it in individual meshes but when its in the foliage object there isnt a setting for it.
For now ive actually just turned off shadows for the distance foliage, the trees are so far in the distance you dont really notice it. Ill give the Ray Traced distance field a try.

The far shadows options is meant really for objects in the distance that may need a shadow for your level. It’s not intended to be used for every object which is why it wouldn’t be an option in the foliage tool. Having every object in the scene to the distance of the far shadows, even just foliage, would be a significant hit to your performance.

Yes, thats why I was wondering if they could not just cast shadows using the static light maps rather than dynamic shadows.

I also found that using high detail trees (20k triangles+) with lods down to 8 triangles in the distance , uses huge amounts of memory for lighting. My scene was using about 4gb ram with lightmass, and took about 15mins to light, but with 500 distant trees it was 18gb+ and almost 2 hours to light. Even though those trees were only 8 tris each in the lod object displayed, i`m assuming it was lighting as if they were the lod0 mesh at 20k tris each?
So I created a tree mesh just for distance that was just a single 8 tri mesh and it fixed that issue.