Shadows do not start at the right place.

I’m made sure that the mesh is inside the floor and not hovering above it.
I’m using the free vegetation pack for my level editor:

4e357be42f8bbfdb9cc1a4f119e700d75152f1ad.jpeg
Maybe this is something in the material, this is how it looks like:

It’s due to the shadow map bias setting in the directional light. You can change it but a too low value can cause shadow map acne. A too high value causes peter-panning, like in your screens. Also shadow map resolution needs to be high enough.

And now I see that even with a simple material that is two sided it gives the same problem.
Capture.JPG

Thanks I will try that.

Ok it seems to fix it but there is no way to get rid of whose artifacts it causes around it?

Unfortunately when you tweak that bias setting you are going to expose that kind of artifact whenever you reduce the offset by too much. The problem is that shadows like this are rendered using the depth of the scene as viewed from the light. In order to keep all surfaces from shadowing themselves, a small offset must be added first.

If this problem is only showing up on your grass mesh, it may be possible to do some slight Vertex push on the foliage meshes along the direction of the light vector. That will let you move the grass over to close the gap but if you move it too far you may see the grass start to shadow itself.

You just need to get light vector (I suggest using material parameter collections) and multiply that times the offset amount and add to WPO.

Ok thanks I will give it a try.