Download

Shadows are too bright

Hi all :slight_smile:

I’ve a question about Unreal render.

My render is nice, but my shadow are too bright. I tried many solutions :

custom LUT

post process volume

skylight option

I found on the web a lot of scene with very nice and dark shadows, like here :

http://www.evermotion.org/vbulletin/attachment.php?attachmentid=167211&d=1471981584

i ve standard light setup, with a Sun, a Skylight, and 2-3 spot light.

What is the tips for to darken my shadows ?

Thank very much

Shadows are the absence of light, so if you have only a source of direct light, the shadows should be pure black. adding fill lighting through either skylights, or post process volumes can wash out the shadows if not used correctly.

You can also adjust the exposure settings in your lightmass importance volume, by default it will try to adjust itself a little bit so if you have some bright spots in the scene then it might make the shadows darker.

@Darthviper > I see nothing in Lightmass Importance Volume. No Exposure, no shadows options.

I ve 4-5 bright spot in my scene but they are “soft”. It’s impossible to modulate intensity shadow otherwise ?
@RyanB > same question : I understand the principe, but I can’t decide to darken my shadows if I want ? :confused:

The Environment Color in the World Settings->Lightmass defines the Colour of Shadows.
Maybe you have changed it?

It’s in post process volume settings. I assume he’s referring to the, rather annoying in my opinion, auto-exposure settings. If you set Min/Max brightness to the same value it will effectively disable it. You can then tweak it from there to better suit your tastes. It can significantly brighten the entire scene even with it’s default settings.

The way you tell is the wrong way to disable. It’s not disabling, just taking ages to calculate. The true way of disabling automatic exposure is from Project Settings menu to Rendering section. I hope I am not wrong about this though, been a while. :stuck_out_tongue:

@Raildex_ > I don’t know to use the lightmap parameters in World setting. So I don’t change it !
@xuri > yes, I changed auto exposure option. But it’s global option, it affects all my lighting. My lighting is nice, I just want to darken a little bit my shadows.

Sorry, I mean to type Post Process Volume

You can use post process, but you really should adjust the lighting as a first reaction rather than trying to tweak with post.

It could also be bounce lighting washing out your scene if its statically lit. Try going into world properties under lightmass and set diffuse boost to 0. Then also set your skylight to 0 and then you should have absolutely black shadows after you rebuild lighting. Then you can slowly enable the bounce and ambient light to your taste (rebuilding after each change).

I would highly suggest you take this route before just messing with post processing since once your post process gets too far away from center it will end up causing issues with everything else you create in the future and you may be really limiting your content range. This can bring out bad precision artifacts etc.

I meant to then tweak it to his liking rather than to permanently disable. :slight_smile:

Ah okay, you said “effectively disable it” so my patriotic instincts triggered. :slight_smile: