Download

Shadow was baked and now I can't take it off no matter what

Hello, I am using Unreal Engine to make my first game.
I know that using static lighting needs you to bake the lighting every time you move something, but I am having some problem with it and really don’t know what is going on.

That is what happens when I bake the lights. There was a garbage can there, and I deleted it (actually deleted, not turned off visibility or something like that), but no matter what it keeps retaining the shadow from the object every time I bake the light.

b410ac757345e72f0fa0afca3141112a6c19434b.jpeg

If I put the garbage can back in place and re-bake the lighting, this is what happens.

ff2e7db43249326ba8e6cd5794b1894c8816ea45.jpeg
(there is no object in the room that should produce this shadow on the garbage can)

6d5bdd665a53414313ce8472c9048bcf5c55be61.jpeg
https://forums.unrealengine.com/core/image/gif;base64

Did Unreal Engine somehow burn the textures? Probably not, because when I delete the garbage can and drag it again on the scene, before baking the lights, it remains normal.
This is really bugging me out, really don’t have any clue left of what it may be. Do you know how to fix this?
Anyways, thanks in advance!

You can delete MapName_BuiltData.uasset. It seems for me, ue4 now have some problems with editing rules in Windows(my input and navigation configs cant be modified through engine). U can check if that file has proper build date an time. You can clean swarm engine cash in Disk:\Users\UserName\AppData\Local\UnrealEngine\4.25\Saved\Swarm too. Also I had issues with lighting using virtual textures in 4.25.1 Duno if it fixed now, but every build without cleaning builtdata and cash was making scene worse and worse, unless its become all green, blue or even yellow - don’t have this issues without virtual textures.

Try checking force no precomputed lighting under your world settings and building all lights again. It should clear all of your baked lighting, uncheck it and build it again. It should be gone. =)