Download

Shadow too dark on one part of a Model

I have a problem, the shadow in the lower part of this cup is defiantly too dark. Through, this model worked just fine, and didn’t had this problem before in a different scene (as far as I know, all settings for Lights and World settings are the same, yet it has the Problems only here - Both times I used Preview Build for Lights, also this is a moveable Object (also in both cases)).
Sadly I also haven’t found anything so far on the Internet that helped, but I am pretty sure I am just overseeing something major here -.- .

//edit: Found the cause: “Worldsettings → Envirenment Color” causes this, when its set to a darker color (default its black on new maps, so too dark)

http://nekros-blog.net/images/private/cup_bug.PNG

*Add a skylight (tweak your values till you find it appropriate) → in options untick lower hemisphere is black, build light and check if it worked!

Best Regards

Thanks for the suggestion, but all it did, was making all shadows lighter - the dark bottom is actually white itself (from the Texture), so the shadow color should be the same as the other inside shadows. (as they are in the other Project).

Weird behaviour.
Maybe normals of this part are inverted, double polys or something like this?

Not the Case, I already Tested the Model with new UVs and it dose the same also without Textures and as I said, its working fine in a different Project (both 4.7).

Found the cause: “Worldsettings → Envirenment Color” causes this, when its set to a darker color (default its black on new maps, so too dark)