Shadow spots on clear coat shader


Can anyone help me please?? I’m getting really weirder marks in my raytraced shadows on clear coat shades like car paints. You can see in the images.

How can I get rid of them?? iv also attached the setting for the Directional Light and my post process volume.

Thanks Andy

Having the same issue with 4.26.1, hoping to get some fix for this soon.

I’ve noticed another issue with Clearcoat shaders since moving to 4.26 - changing the spotlight radius to anything other than the default 0 seems to completely mess the specular on the object with clearcoat shader applied, creating some really weird artifacts.

1 Like

did a bit more digging into this - problem seems to be coming from the Source Angle parameter of the Directional Light. Keeping it at 0 eliminates the weird shadow patches, but of course that means we can’t get nice soft shadows…

Likewise, the bug I mentioned before related to the Spotlight and changing its radius seems to be connected to the Directional Light issue - I am by no means an expert on how graphics work, but so far it looks like the Specular seems to glitch out completely on Clearcoat shaders when using lights with custom Radius/Source Angle values.

1 Like

Hi guys :slight_smile: Still no fix for it?