Download

Shadow problem

Hi,
I have this weired problem with shadows occuring on planks in the middle of the shot. They are on even level, with 0,1cm space between them. Does anyone know why is this happening?

Anyone? Please help.

Hi!

I think it’s going to be your lighmap!
Either badly laid or very low resolution…
I’d say it’s better in every way to have your floor as 1 mesh and make it “planky” with your material…

Could it be the location / influence of the reflection probe in the screenshot? The darker areas show up exclusively within the width of the adjacent, lit hallway. To the left and right of it the planks are tightly aligning. Shadow bleeding can also be caused by something to do with distance field shadowing, such as if the distance field is not entirely covering the mesh / area it’s over. Provide more information about lighting (types of lights, mobility, and a screenshot of their settings) to get further help.

Thank you all very much!
I’ve boosted the lightmass settings , (bounces and quality set higher ,indirect lighting smoothness set to 0.5) and it helped, but not it is still not great. I tried my geometries (from SU, exported with datasmith) in more basic set-up (only skylight), and there are still shadow leaks. As far as I know, im not using field shadowing.
Im affraid that i should change my habbits from SU and MAX, where I always preffered modeling my planks and tiles.

That’s a better approach anyway.

do this.

Take the planks, lay them as you need, make a floor mesh that has the same number of divisions as planks.

Then use the high res planks to bake the normal map for the new flat floor.

In unreal you use the flat floor with the derived normal map which will look 1000% better then anything you can ever download.
because the floor is flat, you won’t have any issues building lights on planks.

Visually you should have no difference at all, unless you actually zoom into the floor enough to see that the planks have no real cuts.