Shadow of Masked Material

I made Masked Material but the shadow of it is much bigger (thicker?) than it’s supposed to be.
Is there some way to make the shadow more precise ?

I was doing some experiments to figure out what is wrong,

Light Map Res of the floor is 1024, even tried 2048,
Light Map Res of the hair-like thing is 512.
Lighting Quality set to Production.
Mip Gen Settings of Base Colour is NoMipmaps.
I tried changing Shading Model “Default Lit” to “Two Sided Foliage” but made no difference.

Does someone know what to do ?
Please help.