Download

Shadow issue on a personnal Props when Building light

Hi there^^.

I just begin with this amazing engine and now facing an issue with shadows.

I made a low poly pilar with cavity and normal in 3ds, and import the fbx in Unreal.
Everything was working fine in my first scene but when i tried to build my light in another scene (with almost the same presets) i got this on the shadows :

bugUnreal.jpg

I tried in preview and medium settings, same result.
I have the basic prest in the world setting for lightmap except i switch to 2 and 3 light bounces.

The only difference with my other scene is that here the ground is a “brush” and in the other scene a “landscape”.

if someone can explain me the tricky bug here^^.

EDIT : i added a lightmass importance volume, a skylight and switch the ground object to a landscape, no changes :S

Thanks.

Hi Bakudan_kun,

Try adjusting the lightmap resolution settings of your floor and the bsps. It may be too low.

Thanks for the tips Adam, i tried to put something like 32 instead of 1 in the “Static Lighting Resolution” of my landscape and it crashed after using all my RAM. So i tried with 2 instead, and it started to show better shadows.

But the problem was not here.
It was in my “Light Source”, the Dynamic Shadow Distance" was set to 0 as default, i turned it to 10-12k and then the real nice shadows appeared. (even with 1 in the landscape Lighting resolution).

So i’m wondering, is that normal to set by default 0 in Cascaded Shadow Maps in a Directionnal Light ? Because it give some crappy bugged shadow^^.

Hi i have the same problem as you i also got 128 light map resolution.
But if i change the Cascaded Shadow Maps it dosent really change any thing and looks the same.

sameerror.PNG

Hi Bukudan_Kun,

There are several things going on here with the shadows I want to take a moment to clarify.

In the first image you posted you wanted to know what was going on with the shadows, because the one in the background was clearly defined while the foreground ones were not. If you look at the top right, it says “Lighting needs to be rebuilt on 1 object” The object with the clearly defined shadows needed to be rebuilt.

UE4 uses lightmaps to store shadow information. The meshes store the shadow information in a texture that is baked. This precomputed light bake information allows the engine to not have to calculate all this lighting at run time freeing up what could potentially use a lot of memory causing FPS drops.

To fix shadow information without using dynamic lighting you would need to adjust your lightmap resolution settings in the details panel for each mesh. The pillars would need to be raised to receive better shadows from other objects. The floor/ground mesh would need it’s lightmap adjusted up to receive better shadows from the pillars or any other objects.

In reference to Dynamic Shadow Distance you are using. This does give you the crisp shadows you want (which can be employed at much lower memory cost by using the method above) but at a high cost. When setting the shadow distance as high as you have, this is rendering all the shadows dynamically when they are within the range that has been specified. (More information here)

Do what’s best for your project, but there are ways to optimize your project to get the most out of your level without taking the hit on performance.

Hopefully this will clarify some of the issues you were seeing and if you have any further questions please let us know.

Thanks!

Tim

In case of BSP Brushes, lower number in lightmap resolution means higher resolution.