Download

Shadow flickering with Temproal AA anti aliasing on.

I’m wondering if there’s a way to fix the shadow flickering with Temproal AA anti aliasing on.

Because with the old FXAA anti aliasing on or without any anti aliasing, the edge of my objects become flickering and my character’s hair looks odd.

If I play with the new cine cam’s lens setting, the edge of my objects looks fine, but my character’s hair still looks odd which from my view port I see a lot of alias around my diffuse map.

BTW, I’m using poly plane hair method and UE 4.12.0.

Need help in urgent. please help. Is there a way to work things around ?

are you sure it’s TemporalAA?
can you show some screenshots?

I think so.

When the light goes through the transparent hair poly plane, with the temporal AA anti aliasing and shadow casting on, it calculates which area should the light goes through and which area should cast some shadow onto another surface.

With the new temporal AA anti aliasing on, when the light goes through the transparent hair poly plane, it not only calculates the regular shadow casting, but also the temporal AA anti aliasing, because the temporal AA anti aliasing has effect on the diffuse and transparent maps of the hair poly plane.

This is my thought. I’m not sure if I’ve made my explanation clear enough to you.

I can’t make any screenshots because the flickering issue is in a motion. When I take screenshots, it freezes, which is not what I want to show you.

well I just wanted to rule out some possibilities. if you’re sure that turning TemporalAA off makes the issue go away then probably someone from Epic should look at it

any suggestion would be appreciated. just shoot your ideas and some possibilities that you think causing this issue. thank you, Chosker.

Does this happen with all shadows? At what angle is the shadow surface in relation to the camera? I have this kind of problem with DF shadows in the distance on flat landscape.

This shadow flickering problem only happens when the light goes through the transparent poly plane.

nvm… I find the problem and fixed it…

Why not posting the solution instead? :confused:
Even in the example level, the hair shadows are flickering when enabled.
What was the fix?

Yep, i’d also love to read the solution.

Yeah a solution post would be greatly appreciated , i think i have the same issue.

I already created a new thread about it and pm’d [MENTION=409530]River Piece[/MENTION], but no reply yet.
The problem could be, that the shadows being calculated after the post processing dithering and they flicker like the yellow selection outline in the editor, from the animated dithering, which fake transparency.
But I don’t know how to tell the engine, to do the dithering after shadow calculation :confused:

We jump into using the hairworks in UE4 because we are making 3d animation so for the FPS part it’s not a big of deal for us.

I am not sure if I’m right but for people who uses poly plane making hair check your noise node in your hair material, that’s the issue causing the hair shadow’s edge flickers.

I guess you might want to make your own noise texture instead of using engine generated noise node because that node is not a still image. For the theory behind it please someone explain it.

Before we jumped into hairworks, I did a little test. I had changed the noise node to my own noise texture and it worked.

But the result of using noise texture hadn’t satisfy me. We could make paragon looking hair but time is a big issue. In addition, hairworks has dynamic on it and easy to adjust.

At the end of the day only result matters; UE4 is a great engine but it still has some limitations. because of this, I would say find some efficient ways that better suit you and try to find a way around it.

I believe this bug can be easily reproduced by just creating some empty project with the “Open World Demo Collection” installed (free from Epic), and placing some SM_Heather_…] bushes to the ground. Their shadows will be flickering.

Wish there was a solid solution as i’m trying to make some cinematic, starting with a close plan to the ground.

Necroing this because I have the exact same issue… I’m surprised this is still an issue [FONT=comic sans ms]4 years later.

I noticed this was only happening when the hair which was using temporal AA was casting a shadow on my character’s skeletal mesh. The problem was resolved after I enabled Dynamic Inset shadow and Light attachment as group on my skeletal mesh. Bam, all shadow problems gone.

Sounds like people are talking about different issues.

  • Shadows will appear to flicker on animated objects due to filtering and low resolution shadow maps. Figure out how a way to improve shadow quality that works for your scene. Increase shadow resolution, increase number of cascades, adjust shadow/cascade distance to improve resolution up close, use screen-space shadows to fill in any gaps and hide flickering, use Dynamic Inset Shadow if your light is stationary(effectively increases resolution but only for the object), try PCSS shadow filtering(trades bias issues and jagged edges for noise basically)
  • The hair materials in the example content take advantage of screen-space noise that is meant to be blurred out through TAA to make an otherwise hard edge appear soft. It’s not necessary at all if you can make hard clumps of hair work. You can also use the ShadowPassSwitch node to disable the noise during the shadow pass, so visually hair is soft but the shadows are hard. You can do other math to make the shadows not as thick if necessary, or roll your own noise.