Shadow Filter Provokes Visible Mesh Faces

If the Shadow Filter Sharpen value is set different from 1, the blured shadow make the triangles of a mesh pretty obvious:

This is notably on my meshes in a close up. My meshes are smoothed and exported correctly. For example in the skeletal mesh preview window, it looks fine.

This picture uses the default values for ‘Shadow Filter Sharpen’ with 0 and ‘Shadow Bias’ with 0.5.


I used shadow settings ‘Epic’. The Sunlight used ‘Num Dynamic Shadow Cascades’ of 4 and a ‘Dynamic Shadow Distance MoveableLight’ of 2500.

Hi ,

This is an artifact of direct shading from your directional light. You can adjust the Cascaded Shadow Maps properties to reduce this.

Thank you!


Thank you Tim for your reply.

The artifacts only vanish when I set ‘Num Dynamic Shadow Cascades’ to 1. However isn’t the purpose for Cascaded Shadow Maps to use multiple shadow map resolutions based on distance? If I only can use one cascaded shadow map, isn’t the feature broken, since I can’t render 4 shadow maps without causing artifacts?